aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gprofng/src/Makefile.am')
-rw-r--r--gprofng/src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gprofng/src/Makefile.am b/gprofng/src/Makefile.am
index 6e0931524e4..268fad95389 100644
--- a/gprofng/src/Makefile.am
+++ b/gprofng/src/Makefile.am
@@ -131,7 +131,8 @@ libgprofng_la_LDFLAGS = -version-info 0:0:0
# Pass -lpthread instead of $(PTHREAD_LIBS) due to $(PTHREAD_LIBS) being empty
# when -nostdlib is passed to libtool.
# See bug 29364 - libgprofng.so: needs to link against -pthread
-libgprofng_la_LIBADD = $(top_builddir)/../opcodes/libopcodes.la \
+libgprofng_la_LIBADD = $(GPROFNG_LIBADD) \
+ $(top_builddir)/../opcodes/libopcodes.la \
$(top_builddir)/../bfd/libbfd.la \
$(GPROFNG_LIBADD) \
-lpthread -ldl