aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-07 00:15:53 -0500
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-07-30 17:07:54 +0200
commit4fe7206bdb207021c50e70f19b2b669b7212e58b (patch)
treee2a1d287f5a666acbaaa35a57455438f6d49293d
parentGentoo: gold/ld: add support for poisoned system directories (diff)
downloadbinutils-gdb-4fe7206bdb207021c50e70f19b2b669b7212e58b.tar.gz
binutils-gdb-4fe7206bdb207021c50e70f19b2b669b7212e58b.tar.bz2
binutils-gdb-4fe7206bdb207021c50e70f19b2b669b7212e58b.zip
Gentoo: libiberty: install PIC version of libiberty.a
This will install a PIC version of libiberty.a by overwriting the non-PIC version of libiberty.a while compiling. We do this because there is no shared version of libiberty for random apps to link against which means if someone wants to use this in a shared library or PIE, they're out of luck. It's arguable whether people should be able to use this in a shared lib, but usage in PIE should be fine. You could argue that this penalizes the non-PIE users, but the counter point is that people using this library in general are fairly low, and we'd rather have things work for all of them. (cherry picked from commit 112aff9ad3e2675556370c4281117a6df0a879d9)
-rw-r--r--libiberty/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/libiberty/Makefile.in b/libiberty/Makefile.in
index f9fbba23e2c..d37488d1bf8 100644
--- a/libiberty/Makefile.in
+++ b/libiberty/Makefile.in
@@ -258,6 +258,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
$(AR) $(AR_FLAGS) $(TARGETLIB) \
$(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
$(RANLIB) $(TARGETLIB); \
+ cp $(TARGETLIB) ../ ; \
cd ..; \
else true; fi; \
if [ x"$(NOASANFLAG)" != x ]; then \