summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch')
-rw-r--r--private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch51
1 files changed, 0 insertions, 51 deletions
diff --git a/private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch b/private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch
deleted file mode 100644
index 1b8a423..0000000
--- a/private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -31,6 +31,9 @@ AC_ARG_WITH(libdb,
- 4.4)
- DB_WANT_VERSION=4.4
- ;;
-+ 4.5)
-+ DB_WANT_VERSION=4.5
-+ ;;
- ?|?.?)
- AC_MSG_ERROR([Unknown --with-libdb argument $withval])
- ;;
-@@ -71,6 +74,12 @@ elif test "x$DB_VERSION_MAJOR" = "x4" -a
- elif test "$DB_WANT_VERSION" != "4.4" ; then
- AC_MSG_ERROR([Found libdb major version $DB_VERSION_MAJOR.$DB_VERSION_MINOR, need $DB_WANT_VERSION])
- fi
-+elif test "x$DB_VERSION_MAJOR" = "x4" -a "x$DB_VERSION_MINOR" = "x5" ; then
-+ if test "$DB_WANT_VERSION" = "any" ; then
-+ DB_WANT_VERSION=4.5
-+ elif test "$DB_WANT_VERSION" != "4.5" ; then
-+ AC_MSG_ERROR([Found libdb major version $DB_VERSION_MAJOR.$DB_VERSION_MINOR, need $DB_WANT_VERSION])
-+ fi
- else
- AC_MSG_ERROR([Unsupported libdb major $DB_VERSION_MAJOR minor $DB_VERSION_MINOR
- Only 4.3 (stronly recommended) or 3.2 or 4.4 are supported])
-@@ -78,6 +87,12 @@ fi
-
- # now we have a header with the expected version, check for the library:
- case "$DB_WANT_VERSION" in
-+4.5)
-+ AC_CHECK_LIB(db-4.5,db_create,[dnl
-+ AC_DEFINE_UNQUOTED(AS_TR_CPP(LIBDB_VERSION),45)
-+ DBLIBS="-ldb-4.5 $DBLIBS"
-+ ],[AC_MSG_ERROR(["no libdb-4.5 found"])],[$DBLIBS])
-+;;
- 4.4)
- AC_CHECK_LIB(db-4.4,db_create,[dnl
- AC_DEFINE_UNQUOTED(AS_TR_CPP(LIBDB_VERSION),44)
---- a/globals.h
-+++ b/globals.h
-@@ -40,7 +40,9 @@ enum config_option_owner { CONFIG_OWNER
- CONFIG_OWNER_FILE,
- CONFIG_OWNER_ENVIRONMENT,
- CONFIG_OWNER_CMDLINE};
--#if LIBDB_VERSION == 44
-+#if LIBDB_VERSION == 45
-+#define DB_OPEN(database,filename,name,type,flags) database->open(database,NULL,filename,name,type,flags,0664)
-+#elif LIBDB_VERSION == 44
- #define DB_OPEN(database,filename,name,type,flags) database->open(database,NULL,filename,name,type,flags,0664)
- #elif LIBDB_VERSION == 43
- #define DB_OPEN(database,filename,name,type,flags) database->open(database,NULL,filename,name,type,flags,0664)