summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/gnome-terminal/gnome-terminal-2.24.1.ebuild')
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-2.24.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/gnome-terminal-2.24.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-2.24.1.ebuild
new file mode 100644
index 0000000..ad887f8
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-2.24.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-2.24.1.ebuild,v 1.1 2008/10/21 01:40:58 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="virtual/xft
+ >=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.13.6
+ >=gnome-base/gconf-2.14
+ >=x11-libs/startup-notification-0.8
+ >=x11-libs/vte-0.17.0
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ gnome-base/gnome-common
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3.11"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Use login shell by default (#12900)
+ epatch "${FILESDIR}"/${PN}-2.22.0-default_shell.patch
+
+ # patch gnome terminal to report as GNOME rather than xterm
+ # This needs to resolve a few bugs (#120294,)
+ # Leave out for now; causing too many problems
+ #epatch ${FILESDIR}/${PN}-2.13.90-TERM-gnome.patch
+
+ # Orange cursor
+ epatch "${FILESDIR}"/${PN}-2.23.6-orange-cursor.patch
+
+ eautomake
+}