summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-04-16 12:43:20 +0200
committerChristoph Mende <angelos@gentoo.org>2011-04-16 12:43:20 +0200
commitf8b3e6e0ba66770d6d3ae2c0a2daa57c1b63f26d (patch)
treef6db9c9cd44ea9cb3caaf52b452420e946c2c653 /scripts
parentmount-chroot: Don't bind distfiles/packages under PORTDIR (diff)
downloadangelos-f8b3e6e0ba66770d6d3ae2c0a2daa57c1b63f26d.tar.gz
angelos-f8b3e6e0ba66770d6d3ae2c0a2daa57c1b63f26d.tar.bz2
angelos-f8b3e6e0ba66770d6d3ae2c0a2daa57c1b63f26d.zip
sync-xfce-overlay.sh: fix cp/sed
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/sync-xfce-overlay.sh7
1 files changed, 4 insertions, 3 deletions
diff --git a/scripts/sync-xfce-overlay.sh b/scripts/sync-xfce-overlay.sh
index 5650228..a96cf55 100755
--- a/scripts/sync-xfce-overlay.sh
+++ b/scripts/sync-xfce-overlay.sh
@@ -24,11 +24,12 @@ for i in ${pkgs}; do
# get destination ebuild's header
dst="${OVERLAY}"/${CAT}/${PN}/${PN}-9999.ebuild
+ dst="${OVERLAY}"/${i}
dstheader=$(grep "^# \$Header: " ${dst})
if [ "${srcheader}" != "${dstheader}" ]; then
# copy new ebuild
- echo cp -f ${src} ${dst}
+ cp -f ${src} ${dst}
# remove any stabl keywords
ekeyword ~all ${dst} >/dev/null
@@ -37,8 +38,8 @@ for i in ${pkgs}; do
# remove SRC_URI
sed -i -e "/^SRC_URI/d" ${dst}
# fix eclass usage
- sed -i -e "/^inherit/s/xfconf/xfconf-live/" ${i}
- sed -i -r "s/xfconf(_(src|pkg))/xfconf-live\1/" ${i}
+ sed -i -e "/^inherit/s/xfconf/xfconf-live/" ${dst}
+ sed -i -r "s/xfconf(_(src|pkg))/xfconf-live\1/" ${dst}
changes+=1
fi