From 557687e4536f9cd9dd404901b2fe0440c4798377 Mon Sep 17 00:00:00 2001
From: Sebastien Fabbro <bicatali@gentoo.org>
Date: Wed, 4 May 2011 00:29:37 +0000
Subject: Version bump

(Portage version: 2.1.9.46/cvs/Linux x86_64)
---
 sci-libs/armadillo/ChangeLog              |  7 +++-
 sci-libs/armadillo/armadillo-1.2.0.ebuild | 60 +++++++++++++++++++++++++++++++
 2 files changed, 66 insertions(+), 1 deletion(-)
 create mode 100644 sci-libs/armadillo/armadillo-1.2.0.ebuild

(limited to 'sci-libs')

diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index 254e59df8cbe..7945d2e2ca16 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for sci-libs/armadillo
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.1 2011/03/06 19:23:25 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.2 2011/05/04 00:29:37 bicatali Exp $
+
+*armadillo-1.2.0 (04 May 2011)
+
+  04 May 2011; Sébastien Fabbro <bicatali@gentoo.org> +armadillo-1.2.0.ebuild:
+  Version bump
 
 *armadillo-1.1.6 (06 Mar 2011)
 
diff --git a/sci-libs/armadillo/armadillo-1.2.0.ebuild b/sci-libs/armadillo/armadillo-1.2.0.ebuild
new file mode 100644
index 000000000000..9054e841231e
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-1.2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-1.2.0.ebuild,v 1.1 2011/05/04 00:29:37 bicatali Exp $
+
+EAPI="3"
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atlas blas doc lapack"
+
+RDEPEND=">=dev-libs/boost-1.34
+	atlas? ( sci-libs/lapack-atlas )
+	blas? ( virtual/blas )
+	lapack? ( virtual/lapack )"
+
+DEPEND="${DEPEND}
+	dev-util/pkgconfig"
+
+src_prepare() {
+	# avoid the automagic cmake macros
+	sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+}
+
+src_configure() {
+	local mycmakeargs=()
+	if use blas; then
+		mycmakeargs+=(
+			-DBLAS_FOUND=ON
+			-DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+		)
+	fi
+	if use lapack; then
+		mycmakeargs+=(
+			-DLAPACK_FOUND=ON
+			-DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+		)
+	fi
+	if use atlas; then
+		mycmakeargs=(
+			-DCBLAS_FOUND=ON
+			-DCLAPACK_FOUND=ON
+			-DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
+			-DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
+			-DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+		)
+	fi
+	cmake-utils_src_configure
+}
+
+src_install() {
+	cmake-utils_src_install
+	use doc && dodoc docs/*pdf
+}
-- 
cgit v1.2.3-65-gdbad