summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/ChangeLog7
-rw-r--r--xfce-base/thunar/files/digest-thunar-0.8.03
-rw-r--r--xfce-base/thunar/thunar-0.8.0.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 720d406baa48..82e3f0f10baf 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.11 2007/01/06 19:10:50 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.12 2007/01/22 02:08:17 nichoj Exp $
+
+*thunar-0.8.0 (22 Jan 2007)
+
+ 22 Jan 2007; Joshua Nichols <nichoj@gentoo.org> +thunar-0.8.0.ebuild:
+ Version bump.
06 Jan 2007; Joshua Nichols <nichoj@gentoo.org> -thunar-0.5.0_rc2.ebuild,
-thunar-0.5.0_rc2-r1.ebuild, -thunar-0.5.0_rc2-r2.ebuild,
diff --git a/xfce-base/thunar/files/digest-thunar-0.8.0 b/xfce-base/thunar/files/digest-thunar-0.8.0
new file mode 100644
index 000000000000..36154971d4f9
--- /dev/null
+++ b/xfce-base/thunar/files/digest-thunar-0.8.0
@@ -0,0 +1,3 @@
+MD5 9f7b0945d6a235391049f6818fb4d188 Thunar-0.8.0.tar.bz2 6205993
+RMD160 95d29cca64c102b7d8bdcc0592f6fcab7198148b Thunar-0.8.0.tar.bz2 6205993
+SHA256 460484f8397a0e0e4115d1629d2ae027b5052dc2c564d4a4629a3557e4a055f9 Thunar-0.8.0.tar.bz2 6205993
diff --git a/xfce-base/thunar/thunar-0.8.0.ebuild b/xfce-base/thunar/thunar-0.8.0.ebuild
new file mode 100644
index 000000000000..f68be1a4731d
--- /dev/null
+++ b/xfce-base/thunar/thunar-0.8.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0.ebuild,v 1.1 2007/01/22 02:08:17 nichoj Exp $
+
+inherit xfce44
+
+MY_P="${P/t/T}"
+S="${WORKDIR}/${MY_P}"
+
+xfce44
+xfce44_extra_package # technically, it's core, but in terms of what the eclass
+ # does, it's more akin to 'extra' -nichoj
+
+DESCRIPTION="Xfce4 file manager"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc dbus debug exif hal pcre startup-notification thumbnail trash-panel-plugin"
+
+# The order of RDEPEND is based on the list in README, by:
+# required packages
+# required packages not listed in README
+# optional packages
+# optional packages not listed
+RDEPEND="
+ >=dev-lang/perl-5.6
+ >=x11-libs/gtk+-2.6.4
+ >=dev-libs/glib-2.6.4
+ >=xfce-extra/exo-0.3.2
+ >=dev-util/intltool-0.30
+ >=media-libs/libpng-1.2.0
+ >=x11-misc/shared-mime-info-0.15
+ >=dev-util/desktop-file-utils-0.10
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ virtual/fam
+ doc? ( >=dev-util/gtk-doc-1 dev-libs/libxslt )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) )
+ )
+ hal? ( >=sys-apps/hal-0.5
+ || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) )
+ )
+ >=media-libs/freetype-2.0
+ thumbnail? ( >=gnome-base/gconf-2.4 )
+ exif? ( >=media-libs/libexif-0.6 )
+ >=media-libs/jpeg-6b
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ pcre? ( >=dev-libs/libpcre-6.0 )
+ trash-panel-plugin? ( dbus? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} ) )
+ "
+
+DEPEND="${RDEPEND}
+ || ( x11-proto/xproto virtual/x11 )"
+
+# TODO report upstream:
+# --enable/disable for jpeg
+# --enable/disable for freetype
+# when those are fixed, we make IUSE="jpeg freetype"
+XFCE_CONFIG="
+ $(use_enable dbus) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc xsltproc) \
+ $(use_enable exif) \
+ $(use_enable pcre) \
+ $(use_enable startup-notification) \
+ $(use_enable thumbnail gnome-thumbnailers) \
+ "
+
+if use hal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=hal"
+else
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
+fi
+
+use trash-panel-plugin && use dbus || XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
+
+pkg_setup() {
+ if use trash-panel-plugin && ! use dbus ; then
+ ewarn "trash-panel-plugin requires ${PN} with dbus support"
+ ewarn "Enable dbus use flag and re-emerge this ebuild if you want this feature."
+ epause 3
+ fi
+}