summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmcliphist')
-rw-r--r--x11-plugins/wmcliphist/ChangeLog7
-rw-r--r--x11-plugins/wmcliphist/files/digest-wmcliphist-0.31
-rw-r--r--x11-plugins/wmcliphist/files/wmcliphist-cflags.patch11
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-0.3.ebuild19
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-0.5.ebuild21
5 files changed, 36 insertions, 23 deletions
diff --git a/x11-plugins/wmcliphist/ChangeLog b/x11-plugins/wmcliphist/ChangeLog
index a74d54466ae0..869120929192 100644
--- a/x11-plugins/wmcliphist/ChangeLog
+++ b/x11-plugins/wmcliphist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmcliphist
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/ChangeLog,v 1.4 2004/06/24 23:06:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/ChangeLog,v 1.5 2004/07/20 11:02:20 s4t4n Exp $
+
+ 20 Jul 2004; Michele Noberasco <s4t4n@gentoo.org> wmcliphist-0.5.ebuild:
+ Fix ebuild to make it produce a working binary. Closes #56782.
+ wmcliphist-0.5.ebuild:
+ Remove old ebuilds.
11 Apr 2004; Jason Wever <weeve@gentoo.org> wmcliphist-0.5.ebuild:
Added ~sparc keyword.
diff --git a/x11-plugins/wmcliphist/files/digest-wmcliphist-0.3 b/x11-plugins/wmcliphist/files/digest-wmcliphist-0.3
deleted file mode 100644
index 7857263d9ae3..000000000000
--- a/x11-plugins/wmcliphist/files/digest-wmcliphist-0.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e3f4cf211a25c0b2ed31a588f81b8d6c wmcliphist-0.3.tar.gz 42947
diff --git a/x11-plugins/wmcliphist/files/wmcliphist-cflags.patch b/x11-plugins/wmcliphist/files/wmcliphist-cflags.patch
new file mode 100644
index 000000000000..47cb0342249b
--- /dev/null
+++ b/x11-plugins/wmcliphist/files/wmcliphist-cflags.patch
@@ -0,0 +1,11 @@
+--- Makefile 2004-07-20 12:51:28.886633728 +0200
++++ Makefile 2004-07-20 12:52:15.305576976 +0200
+@@ -5,7 +5,7 @@
+ DESTDIR = "/usr/local/bin"
+
+ # for normal use
+-CFLAGS = -Wall -O2 -ansi -pedantic $(INCLUDES)
++CFLAGS = -Wall ${GENTOO_CFLAGS} -ansi -pedantic $(INCLUDES)
+ DEBUG =
+
+ # for debuggind purposes
diff --git a/x11-plugins/wmcliphist/wmcliphist-0.3.ebuild b/x11-plugins/wmcliphist/wmcliphist-0.3.ebuild
deleted file mode 100644
index 147240262d14..000000000000
--- a/x11-plugins/wmcliphist/wmcliphist-0.3.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-0.3.ebuild,v 1.5 2004/06/24 23:06:28 agriffis Exp $
-
-IUSE=""
-DESCRIPTION="Dockable clipboard history application for Window Maker"
-HOMEPAGE="http://linux.nawebu.cz/wmcliphist/"
-SRC_URI="http://linux.nawebu.cz/wmcliphist/${P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="x86 amd64 ppc"
-SLOT="0"
-
-DEPEND="virtual/x11"
-
-src_install() {
- dobin wmcliphist
- dodoc ChangeLog README
- newdoc .wmcliphistrc wmcliphistrc.sample
-}
diff --git a/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild b/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild
index d47ec9e05da7..b591c5f64cfc 100644
--- a/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild
+++ b/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild,v 1.7 2004/06/24 23:06:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild,v 1.8 2004/07/20 11:02:20 s4t4n Exp $
+
+inherit eutils
IUSE=""
DESCRIPTION="Dockable clipboard history application for Window Maker"
@@ -12,7 +14,22 @@ SLOT="0"
DEPEND="=x11-libs/gtk+-1.2*"
-src_install() {
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # We patch the Makefile as the original doesn't honour Gentoo CFLAGS
+ epatch ${FILESDIR}/wmcliphist-cflags.patch || die "Source patch failed."
+}
+
+src_compile()
+{
+ emake GENTOO_CFLAGS="${CFLAGS}" || die "Compilation failed."
+}
+
+src_install()
+{
dobin wmcliphist
dodoc ChangeLog README
newdoc .wmcliphistrc wmcliphistrc.sample