summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xmountains')
-rw-r--r--x11-misc/xmountains/ChangeLog9
-rw-r--r--x11-misc/xmountains/xmountains-2.9.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/x11-misc/xmountains/ChangeLog b/x11-misc/xmountains/ChangeLog
index b619ab5974d5..3d7a0e83f003 100644
--- a/x11-misc/xmountains/ChangeLog
+++ b/x11-misc/xmountains/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xmountains
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmountains/ChangeLog,v 1.17 2010/03/15 10:23:47 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmountains/ChangeLog,v 1.18 2011/12/04 07:38:46 jer Exp $
+
+*xmountains-2.9 (04 Dec 2011)
+
+ 04 Dec 2011; Jeroen Roovers <jer@gentoo.org> +xmountains-2.9.ebuild:
+ Version bump.
*xmountains-2.8 (15 Mar 2010)
diff --git a/x11-misc/xmountains/xmountains-2.9.ebuild b/x11-misc/xmountains/xmountains-2.9.ebuild
new file mode 100644
index 000000000000..3442f00333fb
--- /dev/null
+++ b/x11-misc/xmountains/xmountains-2.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmountains/xmountains-2.9.ebuild,v 1.1 2011/12/04 07:38:46 jer Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+MY_P=${P/-/_}
+
+DESCRIPTION="Fractal terrains of snow-capped mountains near water"
+HOMEPAGE="http://www.epcc.ed.ac.uk/~spb/xmountains/"
+SRC_URI="http://www.epcc.ed.ac.uk/~spb/${PN}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-misc/xbitmaps
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # add missing include for strcmp
+ sed -i xmountains.c -e '1a#include <string.h> /* strcmp() */' || die
+ # remove obsolete references to global.*
+ sed -i Makefile.alt README -e 's|global\..||g' || die
+}
+
+src_compile() {
+ emake \
+ -f Makefile.alt \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+ newman ${PN}.man ${PN}.1
+}