summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_auth_openid')
-rw-r--r--www-apache/mod_auth_openid/ChangeLog10
-rw-r--r--www-apache/mod_auth_openid/mod_auth_openid-0.4.ebuild (renamed from www-apache/mod_auth_openid/mod_auth_openid-0.2.ebuild)26
2 files changed, 20 insertions, 16 deletions
diff --git a/www-apache/mod_auth_openid/ChangeLog b/www-apache/mod_auth_openid/ChangeLog
index 8081f283c677..912345d6168e 100644
--- a/www-apache/mod_auth_openid/ChangeLog
+++ b/www-apache/mod_auth_openid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_auth_openid
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/ChangeLog,v 1.2 2008/05/08 19:13:27 hollow Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/ChangeLog,v 1.3 2009/09/17 08:20:05 hollow Exp $
+
+*mod_auth_openid-0.4 (17 Sep 2009)
+
+ 17 Sep 2009; Benedikt Böhm <hollow@gentoo.org>
+ -mod_auth_openid-0.2.ebuild, +mod_auth_openid-0.4.ebuild:
+ version bump
*mod_auth_openid-0.2-r1 (08 May 2008)
diff --git a/www-apache/mod_auth_openid/mod_auth_openid-0.2.ebuild b/www-apache/mod_auth_openid/mod_auth_openid-0.4.ebuild
index a6c1229f2419..5d1370cd8bca 100644
--- a/www-apache/mod_auth_openid/mod_auth_openid-0.2.ebuild
+++ b/www-apache/mod_auth_openid/mod_auth_openid-0.4.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/mod_auth_openid-0.2.ebuild,v 1.1 2008/03/22 19:20:30 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/mod_auth_openid-0.4.ebuild,v 1.1 2009/09/17 08:20:05 hollow Exp $
-inherit eutils apache-module autotools
+EAPI="2"
-DESCRIPTION="an OpenID authentication module for the apache webserver"
+inherit apache-module
+
+DESCRIPTION="An OpenID authentication module for the apache webserver"
HOMEPAGE="http://trac.butterfat.net/public/mod_auth_openid"
SRC_URI="http://butterfat.net/releases/mod_auth_openid/${P}.tar.gz"
@@ -13,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="net-libs/libopkele
+DEPEND=">=net-libs/libopkele-2.0
>=dev-db/sqlite-3"
RDEPEND="${DEPEND}"
@@ -22,18 +24,14 @@ APACHE2_MOD_DEFINE="AUTH_OPENID"
need_apache2
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- AT_M4DIR="acinclude.d"
- eautoreconf
-}
-
-src_compile() {
+src_configure() {
econf --with-apxs="${APXS}" \
--without-bdb-dir \
--with-sqlite3=/usr \
+ --with-apr-config=/usr/bin/apr-1-config \
|| die "econf failed"
+}
+
+src_compile() {
emake || die "emake failed"
}