summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xmbmon/xmbmon-2.0.3.ebuild')
-rw-r--r--sys-apps/xmbmon/xmbmon-2.0.3.ebuild40
1 files changed, 24 insertions, 16 deletions
diff --git a/sys-apps/xmbmon/xmbmon-2.0.3.ebuild b/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
index 08e01d472762..4a644f29945e 100644
--- a/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
+++ b/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
@@ -1,44 +1,52 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xmbmon/xmbmon-2.0.3.ebuild,v 1.1 2003/08/29 12:45:43 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xmbmon/xmbmon-2.0.3.ebuild,v 1.1.1.1 2005/11/30 09:57:02 chriswhite Exp $
+
+inherit gnuconfig eutils
MY_P="${PN}${PV//.}"
DESCRIPTION="Mother Board Monitor Program for X Window System"
HOMEPAGE="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/download.html"
SRC_URI="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/${MY_P}.tar.gz"
+
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86 amd64"
IUSE="X"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
X? ( virtual/x11 )"
-RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/xmbmon-2.0.3-gcc34.patch
+}
+
src_compile() {
+ gnuconfig_update
econf || die "Configure failed"
- emake CFLAGS="$CFLAGS \$(INCLUDES) \$(DEFS)" mbmon || die "Make mbmon failed"
- if use X; then
- emake CFLAGSX="$CFLAGS \$(INCLUDES) \$(DEFS)" xmbmon || die "Make xmbmon failed"
+ emake DEFS="$DEFS -DLINUX" CFLAGS="$CFLAGS \$(INCLUDES) \$(DEFS)" mbmon || die "Make mbmon failed"
+ if use X ; then
+ emake DEFS="$DEFS -DLINUX" CFLAGSX="$CFLAGS \$(INCLUDES) \$(DEFS)" xmbmon || die "Make xmbmon failed"
fi
}
src_install() {
-
dosbin mbmon
fperms 4555 /usr/sbin/mbmon
- fowners root.wheel /usr/sbin/mbmon
+ fowners root:wheel /usr/sbin/mbmon
- if use X; then
+ if use X ; then
dosbin xmbmon
- fperms 4555 /usr/sbin/xmbmon
- fowners root.wheel /usr/sbin/xmbmon
- fi
-
- dodoc 00README*
+ fperms 4555 /usr/sbin/xmbmon
+ fowners root:wheel /usr/sbin/xmbmon
+ fi
+
+ dodoc 00README*
}
pkg_postinst() {
@@ -47,7 +55,7 @@ pkg_postinst() {
einfo "of checking. It is, therefore, very dangerous and may cause"
einfo "a system-crash. Make sure you read 00README.txt,"
einfo "section 4, 'How to use!'"
- echo
+ echo
ewarn "Binaries are setuid root!"
echo
}