summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/tcng/tcng-9h.ebuild')
-rw-r--r--sys-apps/tcng/tcng-9h.ebuild37
1 files changed, 21 insertions, 16 deletions
diff --git a/sys-apps/tcng/tcng-9h.ebuild b/sys-apps/tcng/tcng-9h.ebuild
index 9c4226ad3b71..d208683935bf 100644
--- a/sys-apps/tcng/tcng-9h.ebuild
+++ b/sys-apps/tcng/tcng-9h.ebuild
@@ -1,21 +1,24 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcng/tcng-9h.ebuild,v 1.1 2003/11/15 06:53:43 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcng/tcng-9h.ebuild,v 1.1.1.1 2005/11/30 09:56:39 chriswhite Exp $
+
+inherit eutils
DESCRIPTION="tcng - Traffic Control Next Generation"
HOMEPAGE="http://tcng.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND="doc? ( app-text/ghostscript app-text/tetex media-gfx/transfig )
+# block this to phase it out very shortly
+KEYWORDS="-*"
+IUSE="doc tcsim"
+DEPEND="doc? ( virtual/ghostscript virtual/tetex media-gfx/transfig )
dev-lang/perl
virtual/os-headers
- sys-apps/iproute"
+ sys-apps/iproute2"
RDEPEND="sys-devel/gcc
- tcng-tcsim? ( media-gfx/gnuplot )
+ tcsim? ( media-gfx/gnuplot )
dev-lang/perl
- sys-apps/iproute"
+ sys-apps/iproute2"
IPROUTE_PN="iproute"
IPROUTE_PV="20010824"
@@ -26,8 +29,8 @@ IPROUTE_SRCFILE="iproute2-2.4.7-now-ss${IPROUTE_PV/20}.tar.gz"
# note this project does NOT use the SF mirroring system
SRC_URI="http://tcng.sourceforge.net/dist/${P}.tar.gz
- tcng-tcsim? ( ftp://ftp.inr.ac.ru/ip-routing/${IPROUTE_SRCFILE}
- http://ftp.debian.org/debian/pool/main/i/iproute/${IPROUTE_DEBIAN_PATCH} )"
+ tcsim? ( ftp://ftp.inr.ac.ru/ip-routing/${IPROUTE_SRCFILE}
+ mirror://debian/pool/main/i/iproute/${IPROUTE_DEBIAN_PATCH} )"
S=${WORKDIR}/tcng
IPROUTE_S=${WORKDIR}/${IPROUTE_P}
@@ -36,7 +39,7 @@ src_unpack() {
#unpack tcng
unpack ${P}.tar.gz
- if use tcng-tcsim; then
+ if use tcsim; then
#unpack iproute
unpack ${IPROUTE_SRCFILE}
mv iproute2 iproute-20010824
@@ -50,9 +53,11 @@ src_unpack() {
src_compile() {
local myconf
- use tcng-tcsim && myconf="${myconf} --with-tcsim" || myconf="${myconf} --no-tcsim"
+ use tcsim && myconf="${myconf} --with-tcsim" || myconf="${myconf} --no-tcsim"
+ dodir /usr/bin
+ # configure is NONSTANDARD
./configure \
- --install-directory /usr \
+ --install-directory ${D}/usr \
--no-manual \
${myconf} \
|| die "configure failed"
@@ -69,9 +74,9 @@ src_install() {
dodir /usr
dodir /usr/bin
# fix the install location
- sed 's;INSTALL_DIR=\(.*\);INSTALL_DIR=${D}\1;g' -i config
- make install-tcc || die "make install-tcc failed"
- if use tcng-tcsim; then
+ export TCNG_INSTALL_CWD="/usr"
+ einstall install-tcc || die "make install-tcc failed"
+ if use tcsim; then
make install-tcsim install-tests || die "make install-tcsim install-tests failed"
fi