summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pcmcia-cs')
-rw-r--r--sys-apps/pcmcia-cs/ChangeLog6
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.8.ebuild37
2 files changed, 26 insertions, 17 deletions
diff --git a/sys-apps/pcmcia-cs/ChangeLog b/sys-apps/pcmcia-cs/ChangeLog
index bb2bac0a3e3f..72bd81650f96 100644
--- a/sys-apps/pcmcia-cs/ChangeLog
+++ b/sys-apps/pcmcia-cs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/pcmcia-cs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.83 2005/04/29 12:24:37 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.84 2005/05/04 09:40:04 brix Exp $
+
+ 04 May 2005; <brix@gentoo.org> pcmcia-cs-3.2.8.ebuild:
+ Require in-kernel PCMCIA support for 2.6.x, warn users about in-kernel
+ PCMCIA support under 2.4.x
29 Apr 2005; <brix@gentoo.org> files/pcmcia-cs-3.2.8-ppc.config.opts:
Fixed bug #90463.
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8.ebuild
index c01543f354af..7ccc12da4c0f 100644
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8.ebuild
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8.ebuild,v 1.1 2005/04/25 12:09:18 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.8.ebuild,v 1.2 2005/05/04 09:40:04 brix Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -21,6 +21,26 @@ RDEPEND="X? ( virtual/x11
!gtk2? ( =x11-libs/gtk+-1* ))
xforms? ( x11-libs/xforms ))"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 5 && linux_chkconfig_present PCMCIA; then
+ ewarn
+ ewarn "The recommended configuration for linux-2.4.x is to disable"
+ ewarn "CONFIG_PCMCIA in the kernel and use the drivers from"
+ ewarn "sys-apps/pcmcia-cs-modules."
+ ewarn
+ elif kernel_is gt 2 4 && ! (linux_chkconfig_present PCMCIA || linux_chkconfig_present PCCARD); then
+ eerror
+ eerror "The package requires the in-kernel PCMCIA drivers to be enabled"
+ eerror "for kernel 2.6.x."
+ eerror
+ die "linux-${KV_FULL} without PCMCIA support detected"
+ fi
+}
+
+
src_unpack() {
unpack ${A}
@@ -124,18 +144,3 @@ src_install () {
dodoc BUGS CHANGES MAINTAINERS README README-2.4 \
SUPPORTED.CARDS doc/*
}
-
-pkg_postinst() {
- if kernel_is lt 2 5; then
- einfo
- einfo "The recommended configuration for linux-2.4.x is to disable"
- einfo "CONFIG_PCMCIA in the kernel and use the drivers from"
- einfo "sys-apps/pcmcia-cs-modules."
- einfo
- else
- einfo
- einfo "The recommended configuration for linux-2.6.x is to use"
- einfo "the in-kernel PCMCIA drivers."
- einfo
- fi
-}