summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.27.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.27.ebuild40
1 files changed, 14 insertions, 26 deletions
diff --git a/sys-apps/modutils/modutils-2.4.27.ebuild b/sys-apps/modutils/modutils-2.4.27.ebuild
index eb633ca77d32..1212531260d5 100644
--- a/sys-apps/modutils/modutils-2.4.27.ebuild
+++ b/sys-apps/modutils/modutils-2.4.27.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.27.ebuild,v 1.1 2004/08/24 23:37:47 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.27.ebuild,v 1.1.1.1 2005/11/30 09:56:45 chriswhite Exp $
-inherit flag-o-matic eutils
+inherit eutils
DESCRIPTION="Standard kernel module utilities"
HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/modutils/"
@@ -10,44 +10,32 @@ SRC_URI="mirror://kernel/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa -amd64 ~ia64 ~ppc64 ~s390"
+KEYWORDS="alpha -amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND="virtual/libc
+ !virtual/modutils"
PROVIDE="virtual/modutils"
src_unpack() {
unpack ${A}
-
- EPATCH_OPTS="-d ${S}/util" \
- epatch ${FILESDIR}/alias.h.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-alias.patch
+ epatch "${FILESDIR}"/${P}-gcc.patch
+ epatch "${FILESDIR}"/${P}-flex.patch
}
src_compile() {
- local myconf=
- local mymake=
-
- # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
- #
- # Final resolution ... dont make it link against zlib, as the static
- # version do not want to autoload modules :(
- myconf="${myconf} --disable-zlib"
-
- [ ${ARCH} = "hppa" ] && mymake="ARCH=hppa"
-
econf \
--prefix=/ \
--disable-strip \
--enable-insmod-static \
- ${myconf} || die "./configure failed"
-
- emake ${mymake} || die "emake failed"
+ --disable-zlib \
+ || die "./configure failed"
+ emake || die "emake failed"
}
src_install() {
- local mymake=
- [ ${ARCH} = "hppa" ] && mymake="ARCH=hppa"
- einstall prefix="${D}" ${mymake} || die "make install failed"
-
+ einstall prefix="${D}" || die "make install failed"
dodoc CREDITS ChangeLog NEWS README TODO
}