summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/szip/szip-2.1.ebuild')
-rw-r--r--sci-libs/szip/szip-2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/szip/szip-2.1.ebuild b/sci-libs/szip/szip-2.1.ebuild
new file mode 100644
index 000000000000..0ebdaeb8c349
--- /dev/null
+++ b/sci-libs/szip/szip-2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/szip/szip-2.1.ebuild,v 1.1 2007/11/03 19:21:50 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Implementation of the extended-Rice lossless compression algorithm"
+HOMEPAGE="http://hdf.ncsa.uiuc.edu/doc_resource/SZIP/"
+SRC_URI="ftp://ftp.hdfgroup.org/lib-external/${PN}/${PV}/${P}.tar.gz"
+LICENSE="szip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ # fix example with adding -lm
+ cd "${S}"
+ epatch "${FILESDIR}"/szip-2.0-example.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc RELEASE.txt || die
+}