summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog5
-rw-r--r--net-www/apache/apache-2.0.54-r6.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 53c097eca9c5..0a6f204e9c95 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/apache
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.372 2005/06/01 09:03:03 urilith Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.373 2005/06/01 19:17:58 urilith Exp $
+
+ 01 Jun 2005; Michael Tindal <urilith@gentoo.org> apache-2.0.54-r6.ebuild:
+ Fix the ebuild not selecting a default MPM if no MPM use flags are present.
*apache-2.0.54-r6 (01 Jun 2005)
diff --git a/net-www/apache/apache-2.0.54-r6.ebuild b/net-www/apache/apache-2.0.54-r6.ebuild
index 5ae5c72be511..f4166f7d0a42 100644
--- a/net-www/apache/apache-2.0.54-r6.ebuild
+++ b/net-www/apache/apache-2.0.54-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r6.ebuild,v 1.2 2005/06/01 10:06:34 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r6.ebuild,v 1.3 2005/06/01 19:17:58 urilith Exp $
inherit eutils gnuconfig
@@ -394,10 +394,10 @@ select_mpms() {
if [ "x${mpm}" = "x" ]; then
if useq threads; then
einfo "Threads specified without a mpm-specification, using mpm-worker."
- mpms="worker"
+ mpm="worker"
else
einfo "No MPM style was specified, defaulting to mpm-prefork."
- mpms="prefork"
+ mpm="prefork"
fi
fi
}