summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/d4x/d4x-2.4.1-r1.ebuild')
-rw-r--r--net-misc/d4x/d4x-2.4.1-r1.ebuild42
1 files changed, 18 insertions, 24 deletions
diff --git a/net-misc/d4x/d4x-2.4.1-r1.ebuild b/net-misc/d4x/d4x-2.4.1-r1.ebuild
index c006a18ae797..47b1e3d206c6 100644
--- a/net-misc/d4x/d4x-2.4.1-r1.ebuild
+++ b/net-misc/d4x/d4x-2.4.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/d4x/d4x-2.4.1-r1.ebuild,v 1.1 2003/03/30 17:46:30 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/d4x/d4x-2.4.1-r1.ebuild,v 1.1.1.1 2005/11/30 09:55:17 chriswhite Exp $
IUSE="nls esd gnome oss kde"
@@ -11,13 +11,13 @@ DESCRIPTION="GTK based download manager for X."
SRC_URI="http://www.krasu.ru/soft/chuchelo/files/${P/_}.tar.gz"
HOMEPAGE="http://www.krasu.ru/soft/chuchelo/"
-KEYWORDS="~x86"
+KEYWORDS="x86 sparc"
SLOT="0"
LICENSE="Artistic"
DEPEND=">=x11-libs/gtk+-2.0.6
>=dev-libs/glib-2.0.6
- >=sys-devel/gettext-0.11.2
+ >=sys-devel/gettext-0.11.2
esd? ( >=media-sound/esound-0.2.7 )"
src_unpack() {
@@ -33,27 +33,22 @@ src_unpack() {
# Fix a miscompile with gcc-3.2.2 and CFLAGS="-O2"
# <azarah@gentoo.org> (30 Mar 2003)
epatch ${FILESDIR}/${P}-fix-statusbar-crash.patch
+
+ # Fix bad #elif directives in sndserv.cc for big endian machines
+ # <weeve@gentoo.org> (28 Mar 2004)
+ use sparc && epatch ${FILESDIR}/${PN}-sndserv-bigendian.patch
}
src_compile() {
- myconf=""
-
- use nls \
- && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
-
- use esd \
- && myconf="${myconf} --enable-esd" \
- || myconf="${myconf} --disable-esd"
-
- use oss \
- && myconf="${myconf} --enable-oss" \
- || myconf="${myconf} --disable-oss"
-
econf --enable-release \
- ${myconf} || die
-
+ $(use_enable oss) \
+ $(use_enable esd) \
+ $(use_enable nls) || die "econf failed"
+
+ # workaround unsupported gtk_ calls for >=x11-libs/gtk+-2.2.4
+ sed -e 's:.*GTK_DISABLE_DEPRECATED.*::' -i ${S}/config.h
+
emake || die
}
@@ -67,15 +62,15 @@ src_install () {
insinto /usr/share/pixmaps
doins share/*.png share/*.xpm
- if [ -n "`use kde`" ]
+ if use kde
then
insinto /usr/share/applnk/Internet
newins share/nt.desktop d4x.desktop
fi
- if [ -n "`use gnome`" ]
+ if use gnome
then
- echo "Categories=Application;Network;" >> ${S}/share/nt.desktop
+ echo "Categories=Application;Network;" >> ${S}/share/nt.desktop
insinto /usr/share/applications
newins share/nt.desktop d4x.desktop
fi
@@ -84,4 +79,3 @@ src_install () {
dodoc AUTHORS COPYING ChangeLog* NEWS PLANS TODO \
DOC/{FAQ*,LICENSE,NAMES,README*,TROUBLES,THANKS}
}
-