summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog15
-rw-r--r--net-ftp/lftp/files/configure-lftp-2.6.2.diff21
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.6.21
-rw-r--r--net-ftp/lftp/lftp-2.6.2.ebuild66
4 files changed, 102 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index a065ae895970..5ad528c894c5 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.11 2002/08/25 16:51:53 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.12 2002/09/11 16:51:00 raker Exp $
+
+*lftp-2.6.2 (11 Sep 2002)
+
+ 11 Sep 2002; Nick Hadaway <raker@gentoo.org> lftp-2.6.2.ebuild,
+ files/digest-lftp-2.6.2 :
+ Version bump. readline history is now stored in a file.
+ handle full-disk condition as fatal if the file is removed.
+ recursive deletion (rm -r) fixed. It used DELE instead of RMD.
+ fixed a rare core dump, usually happening on completion.
+ fixed compilation with modules. nls use variable appears to work
+ with this version as well. Undoing temporary forcing of nls.
+ Patched configure so adding ssl support doesn't add the dreaded
+ -I/usr/include flag. gcc3 is much happier now. :)
*lftp-2.6.1 (13 Aug 2002)
diff --git a/net-ftp/lftp/files/configure-lftp-2.6.2.diff b/net-ftp/lftp/files/configure-lftp-2.6.2.diff
new file mode 100644
index 000000000000..132456081104
--- /dev/null
+++ b/net-ftp/lftp/files/configure-lftp-2.6.2.diff
@@ -0,0 +1,21 @@
+diff -urN lftp-2.6.2/configure lftp-2.6.2-modified/configure
+--- lftp-2.6.2/configure Tue Sep 10 07:42:35 2002
++++ lftp-2.6.2-modified/configure Wed Sep 11 11:45:31 2002
+@@ -19227,7 +19227,7 @@
+ LIBS="$LIBS -lssl -lcrypto"
+ if test $loc != default; then
+ LDFLAGS="$LDFLAGS -L$loc/lib"
+- CPPFLAGS="$CPPFLAGS -I$loc/include"
++ CPPFLAGS="$CPPFLAGS"
+ fi
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+@@ -19273,7 +19273,7 @@
+ lftp_cv_ssl="SSL_LIBS=\"-lssl -lcrypto\""
+ if test $found_loc != default; then
+ lftp_cv_ssl="$lftp_cv_ssl SSL_LDFLAGS=-L$found_loc/lib"
+- lftp_cv_ssl="$lftp_cv_ssl SSL_CPPFLAGS=-I$found_loc/include"
++ lftp_cv_ssl="$lftp_cv_ssl"
+ fi
+ break;
+ fi
diff --git a/net-ftp/lftp/files/digest-lftp-2.6.2 b/net-ftp/lftp/files/digest-lftp-2.6.2
new file mode 100644
index 000000000000..297da82a00c9
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.6.2
@@ -0,0 +1 @@
+MD5 914d95bfca4d0d3c41d9b742aa7946c3 lftp-2.6.2.tar.bz2 1126959
diff --git a/net-ftp/lftp/lftp-2.6.2.ebuild b/net-ftp/lftp/lftp-2.6.2.ebuild
new file mode 100644
index 000000000000..6d4e9928415b
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.6.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.2.ebuild,v 1.1 2002/09/11 16:51:00 raker Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="LFTP is a sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/configure-lftp-2.6.2.diff \
+ || die "patch failed"
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socks5" \
+ || myconf="${myconf} --without-socks5"
+
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+
+}