summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/zabbix-agent/ChangeLog11
-rw-r--r--net-analyzer/zabbix-agent/files/1.1/init.d/zabbix-agentd22
-rw-r--r--net-analyzer/zabbix-agent/files/1.1/zabbix_agent.conf25
-rw-r--r--net-analyzer/zabbix-agent/files/1.1/zabbix_agentd.conf70
-rw-r--r--net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.13
-rw-r--r--net-analyzer/zabbix-agent/metadata.xml16
-rw-r--r--net-analyzer/zabbix-agent/zabbix-agent-1.1.ebuild63
7 files changed, 203 insertions, 7 deletions
diff --git a/net-analyzer/zabbix-agent/ChangeLog b/net-analyzer/zabbix-agent/ChangeLog
index 68fedb5f0e01..f6ed827155fe 100644
--- a/net-analyzer/zabbix-agent/ChangeLog
+++ b/net-analyzer/zabbix-agent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/zabbix-agent
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/ChangeLog,v 1.5 2005/12/31 13:43:32 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/ChangeLog,v 1.6 2006/06/06 13:03:26 wschlich Exp $
+
+*zabbix-agent-1.1 (06 Jun 2006)
+
+ 06 Jun 2006; Wolfram Schlich <wschlich@gentoo.org>
+ +files/1.1/init.d/zabbix-agentd, +files/1.1/zabbix_agent.conf,
+ +files/1.1/zabbix_agentd.conf, metadata.xml, +zabbix-agent-1.1.ebuild:
+ maintainer takeover, version bump
31 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
zabbix-agent-1.0.ebuild:
diff --git a/net-analyzer/zabbix-agent/files/1.1/init.d/zabbix-agentd b/net-analyzer/zabbix-agent/files/1.1/init.d/zabbix-agentd
new file mode 100644
index 000000000000..1524ad239666
--- /dev/null
+++ b/net-analyzer/zabbix-agent/files/1.1/init.d/zabbix-agentd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/files/1.1/init.d/zabbix-agentd,v 1.1 2006/06/06 13:03:26 wschlich Exp $
+
+depend() {
+ need net
+ provide zabbix-agent
+ use zabbix-server
+}
+
+start() {
+ ebegin "Starting Zabbix agent"
+ start-stop-daemon --start -c zabbix:zabbix --exec /usr/sbin/zabbix_agentd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Zabbix agent"
+ start-stop-daemon --stop -u zabbix --pidfile /var/run/zabbix/zabbix_agentd.pid
+ eend $?
+}
diff --git a/net-analyzer/zabbix-agent/files/1.1/zabbix_agent.conf b/net-analyzer/zabbix-agent/files/1.1/zabbix_agent.conf
new file mode 100644
index 000000000000..42997388900e
--- /dev/null
+++ b/net-analyzer/zabbix-agent/files/1.1/zabbix_agent.conf
@@ -0,0 +1,25 @@
+# This is config file for zabbix_agent
+# To get more information about ZABBIX,
+# go http://www.zabbix.com
+
+# IP address of ZABBIX server
+# Connections from other hosts will be denied
+Server=127.0.0.1
+
+# Spend no more than Timeout seconds on processing
+# Must be between 1 and 30
+Timeout=3
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+# Format: UserParameter=<key>,<shell command>
+# Note that shell command must not return empty string or EOL only
+#UserParameter=system.test,who|wc -l
+### Set of parameter for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
diff --git a/net-analyzer/zabbix-agent/files/1.1/zabbix_agentd.conf b/net-analyzer/zabbix-agent/files/1.1/zabbix_agentd.conf
new file mode 100644
index 000000000000..e040f17efcc9
--- /dev/null
+++ b/net-analyzer/zabbix-agent/files/1.1/zabbix_agentd.conf
@@ -0,0 +1,70 @@
+# This is config file for zabbix_agentd
+# To get more information about ZABBIX, go http://www.zabbix.com
+
+############ GENERAL PARAMETERS #################
+
+# List of comma delimited IP addresses (or hostnames) of ZABBIX servers.
+# No spaces allowed. First entry is used for sending active checks.
+# Note that hostnames must resolve hostname->IP address and
+# IP address->hostname.
+Server=127.0.0.1
+
+# Server port for sending active checks
+ServerPort=10051
+
+# Unique hostname. Required for active checks.
+Hostname=localhost
+
+# Listen port. Default is 10050
+ListenPort=10050
+
+# IP address to bind agent
+# If missing, bind to all available IPs
+ListenIP=127.0.0.1
+
+# Number of pre-forked instances of zabbix_agentd.
+# Default value is 5
+# This parameter must be between 1 and 16
+StartAgents=5
+
+# How often refresh list of active checks. 2 minutes by default.
+#RefreshActiveChecks=120
+
+# Disable active checks. The agent will work in passive mode listening server.
+#DisableActive=1
+
+# Enable remote commands for ZABBIX agent. By default remote commands disabled.
+#EnableRemoteCommands=1
+
+# Specifies debug level
+# 0 - debug is not created
+# 1 - critical information
+# 2 - error information
+# 3 - warnings (default)
+# 4 - for debugging (produces lots of information)
+DebugLevel=3
+
+# Name of PID file
+PidFile=/var/run/zabbix/zabbix_agentd.pid
+
+# Name of log file.
+# If not set, syslog will be used
+LogFile=/var/log/zabbix/zabbix_agentd.log
+
+# Spend no more than Timeout seconds on processing
+# Must be between 1 and 30
+Timeout=3
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+# Format: UserParameter=<key>,<shell command>
+# Note that shell command must not return empty string or EOL only
+#UserParameter=system.test,who|wc -l
+### Set of parameter for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
diff --git a/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1 b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1
new file mode 100644
index 000000000000..70bfbcd9a4ca
--- /dev/null
+++ b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1
@@ -0,0 +1,3 @@
+MD5 9697e5634547d9614963db04f6cd87d7 zabbix-1.1.tar.gz 1110644
+RMD160 4ef49a92117ef4aa9a2369d49008582f7db14b5f zabbix-1.1.tar.gz 1110644
+SHA256 c544e8b1ba9e3fc62ed283bab058ad753cf3e9ed39ab2aee97c75d483ddfcfa5 zabbix-1.1.tar.gz 1110644
diff --git a/net-analyzer/zabbix-agent/metadata.xml b/net-analyzer/zabbix-agent/metadata.xml
index ec5e1eecd67c..33eb6f00d9b8 100644
--- a/net-analyzer/zabbix-agent/metadata.xml
+++ b/net-analyzer/zabbix-agent/metadata.xml
@@ -1,10 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-
<pkgmetadata>
<herd>no-herd</herd>
- <maintainer>
- <email>iggy@gentoo.org</email>
- </maintainer>
- <longdescription>ZABBIX is software for monitoring of your applications, network and servers.</longdescription>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+ZABBIX is software for monitoring of your applications, network and servers.
+ZABBIX supports both polling and trapping techniques to collect data from
+monitored hosts. A flexible notification mechanism allows easy and quickly
+configure different types of notifications for pre-defined events.
+</longdescription>
</pkgmetadata>
diff --git a/net-analyzer/zabbix-agent/zabbix-agent-1.1.ebuild b/net-analyzer/zabbix-agent/zabbix-agent-1.1.ebuild
new file mode 100644
index 000000000000..1bad41f65df9
--- /dev/null
+++ b/net-analyzer/zabbix-agent/zabbix-agent-1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/zabbix-agent-1.1.ebuild,v 1.1 2006/06/06 13:03:26 wschlich Exp $
+
+inherit eutils
+
+MY_P=${PN//-agent/}
+MY_PV=${PV//_/}
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers. Agent part."
+HOMEPAGE="http://www.zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${MY_P}-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}-${MY_PV}
+
+pkg_preinst() {
+ enewgroup zabbix
+ enewuser zabbix -1 -1 /dev/null zabbix
+}
+
+src_compile() {
+ econf --enable-agent || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir \
+ /etc/zabbix \
+ /var/log/zabbix \
+ /var/run/zabbix
+ keepdir \
+ /etc/zabbix \
+ /var/log/zabbix \
+ /var/run/zabbix
+ insinto /etc/zabbix
+ doins \
+ ${FILESDIR}/${PV}/zabbix_agent.conf \
+ ${FILESDIR}/${PV}/zabbix_agentd.conf
+ doinitd ${FILESDIR}/${PV}/init.d/zabbix-agentd
+ dosbin \
+ src/zabbix_agent/zabbix_agent \
+ src/zabbix_agent/zabbix_agentd
+ dobin \
+ src/zabbix_sender/zabbix_sender \
+ src/zabbix_sender/zabbix_get
+ fowners zabbix:zabbix \
+ /etc/zabbix \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf \
+ /var/log/zabbix \
+ /var/run/zabbix
+ fperms 0750 \
+ /etc/zabbix \
+ /var/log/zabbix \
+ /var/run/zabbix
+ fperms 0640 \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+}