summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/cxfe')
-rw-r--r--media-video/cxfe/ChangeLog7
-rw-r--r--media-video/cxfe/cxfe-0.9.1.ebuild10
-rw-r--r--media-video/cxfe/files/gcc-2.95-fix.patch23
-rw-r--r--media-video/cxfe/files/max-osd-fix.patch34
-rw-r--r--media-video/cxfe/files/xv-default.patch20
5 files changed, 90 insertions, 4 deletions
diff --git a/media-video/cxfe/ChangeLog b/media-video/cxfe/ChangeLog
index ade8d59e5d08..3dcbb6e7e934 100644
--- a/media-video/cxfe/ChangeLog
+++ b/media-video/cxfe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cxfe
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cxfe/ChangeLog,v 1.5 2004/11/28 15:51:03 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cxfe/ChangeLog,v 1.6 2005/01/13 03:17:28 arj Exp $
+
+ 13 Jan 2005; Anders Rune Jensen <arj@gentoo.org> cxfe-0.9.1.ebuild:
+ Tested and works on amd64. 3 Patches, one to fix OSD, another to
+ make it compile on gcc 2.95 and the last to make xv the default output
+ device.
*cxfe-0.9.1 (28 Nov 2004)
diff --git a/media-video/cxfe/cxfe-0.9.1.ebuild b/media-video/cxfe/cxfe-0.9.1.ebuild
index f24547cb4ea9..153bd5cabf7c 100644
--- a/media-video/cxfe/cxfe-0.9.1.ebuild
+++ b/media-video/cxfe/cxfe-0.9.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cxfe/cxfe-0.9.1.ebuild,v 1.1 2004/11/28 15:51:03 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cxfe/cxfe-0.9.1.ebuild,v 1.2 2005/01/13 03:17:28 arj Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.rtwnetwork.com/pub/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 amd64"
IUSE="lirc"
DEPEND=">=media-libs/xine-lib-1_rc1
@@ -22,6 +22,10 @@ DEPEND=">=media-libs/xine-lib-1_rc1
src_unpack() {
unpack ${A}
mv cxfe ${P}
+ cd ${P}
+ epatch ${FILESDIR}/gcc-2.95-fix.patch
+ epatch ${FILESDIR}/max-osd-fix.patch
+ epatch ${FILESDIR}/xv-default.patch
}
src_install() {
diff --git a/media-video/cxfe/files/gcc-2.95-fix.patch b/media-video/cxfe/files/gcc-2.95-fix.patch
new file mode 100644
index 000000000000..9f1b1e4b4eb2
--- /dev/null
+++ b/media-video/cxfe/files/gcc-2.95-fix.patch
@@ -0,0 +1,23 @@
+--- cxfe/cxfe.c 2004-11-27 03:07:59.000000000 +0100
++++ cxfe-0.91/cxfe.c 2004-11-30 11:32:48.230792288 +0100
+@@ -955,6 +955,9 @@
+ static pthread_t lirc_thread;
+ static pthread_t osd_thread;
+ int err;
++ int dvd_mrl = 0;
++ int vcd_mrl = 0;
++ int cd_mrl = 0;
+ /* default values */
+ fullscreen = 0;
+
+@@ -1075,10 +1078,6 @@
+ xine_init(cxfe.xine);
+
+ // check which mrl types was specified:
+- int dvd_mrl = 0;
+- int vcd_mrl = 0;
+- int cd_mrl = 0;
+-
+ for(i = 0; i < m; i++){
+ if (strstr(mrl[i], "dvd:"))
+ dvd_mrl = 1;
diff --git a/media-video/cxfe/files/max-osd-fix.patch b/media-video/cxfe/files/max-osd-fix.patch
new file mode 100644
index 000000000000..e6fc4660f110
--- /dev/null
+++ b/media-video/cxfe/files/max-osd-fix.patch
@@ -0,0 +1,34 @@
+--- cxfe.c 2004-11-27 03:07:59.000000000 +0100
++++ cxfe-max-osd.c 2004-12-11 18:22:29.171711112 +0100
+@@ -125,11 +125,22 @@
+ // if(fbxine.osd.enabled) {
+ va_list args;
+ char *buf;
+- int n, size = 100;
++ int n, size = 47;
+
+ if((buf = xine_xmalloc(size)) == NULL)
+ return;
+
++ va_start(args, info);
++ n = vsnprintf(buf, size, info, args);
++ va_end(args);
++
++ buf = realloc(buf, size+3);
++ buf[size-1] = '.';
++ buf[size] = '.';
++ buf[size+1] = '.';
++ buf[size+2] = '\0';
++
++#if 0
+ while(1) {
+
+ va_start(args, info);
+@@ -147,6 +158,7 @@
+ if((buf = realloc(buf, size)) == NULL)
+ return;
+ }
++#endif
+
+ xine_osd_clear(osd);
+
diff --git a/media-video/cxfe/files/xv-default.patch b/media-video/cxfe/files/xv-default.patch
new file mode 100644
index 000000000000..a42bad2ca66f
--- /dev/null
+++ b/media-video/cxfe/files/xv-default.patch
@@ -0,0 +1,20 @@
+--- ../cxfe/cxfe.c 2004-11-27 03:07:59.000000000 +0100
++++ cxfe.c 2005-01-13 11:52:28.346389672 +0100
+@@ -938,7 +938,7 @@
+ char configfile[2048];
+ x11_visual_t vis;
+ double res_h, res_v;
+- char *vo_driver = "auto";
++ char *vo_driver = "xv";
+ char *ao_driver = "auto";
+ char *mrl[1000];
+ char *cda_param = "input.cdda_device";
+@@ -960,7 +960,7 @@
+
+
+ if(argc <= 1) {
+- printf("Please specify at minimum a video driver and an mrl\n");
++ printf("Please specify a mrl\n");
+ printf("For help enter cxfe --help\n");
+ return 1;
+ }