summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsbsms')
-rw-r--r--media-libs/libsbsms/ChangeLog8
-rw-r--r--media-libs/libsbsms/libsbsms-2.0.0.ebuild8
-rw-r--r--media-libs/libsbsms/libsbsms-2.0.1.ebuild8
-rw-r--r--media-libs/libsbsms/libsbsms-2.0.2.ebuild8
4 files changed, 18 insertions, 14 deletions
diff --git a/media-libs/libsbsms/ChangeLog b/media-libs/libsbsms/ChangeLog
index 9644f2fc0d82..8536fc60b0fb 100644
--- a/media-libs/libsbsms/ChangeLog
+++ b/media-libs/libsbsms/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsbsms
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsbsms/ChangeLog,v 1.9 2014/10/10 04:29:01 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsbsms/ChangeLog,v 1.10 2015/01/29 17:41:44 mgorny Exp $
+
+ 29 Jan 2015; Michał Górny <mgorny@gentoo.org> libsbsms-2.0.0.ebuild,
+ libsbsms-2.0.1.ebuild, libsbsms-2.0.2.ebuild:
+ Switch to CPU_FLAGS_X86.
*libsbsms-2.0.2 (10 Oct 2014)
diff --git a/media-libs/libsbsms/libsbsms-2.0.0.ebuild b/media-libs/libsbsms/libsbsms-2.0.0.ebuild
index b12349b8149b..747b70939c04 100644
--- a/media-libs/libsbsms/libsbsms-2.0.0.ebuild
+++ b/media-libs/libsbsms/libsbsms-2.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsbsms/libsbsms-2.0.0.ebuild,v 1.2 2013/03/10 14:18:44 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsbsms/libsbsms-2.0.0.ebuild,v 1.3 2015/01/29 17:41:44 mgorny Exp $
EAPI=4
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/sbsms/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="sse static-libs"
+IUSE="cpu_flags_x86_sse static-libs"
src_prepare() {
epatch "${FILESDIR}"/${P}-cflags.patch
@@ -24,7 +24,7 @@ src_configure() {
econf \
--enable-shared \
$(use_enable static-libs static) \
- $(use_enable sse) \
+ $(use_enable cpu_flags_x86_sse sse) \
--disable-multithreaded
# threaded version causes segfaults
}
diff --git a/media-libs/libsbsms/libsbsms-2.0.1.ebuild b/media-libs/libsbsms/libsbsms-2.0.1.ebuild
index 90f7c9456913..454ab9191036 100644
--- a/media-libs/libsbsms/libsbsms-2.0.1.ebuild
+++ b/media-libs/libsbsms/libsbsms-2.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsbsms/libsbsms-2.0.1.ebuild,v 1.7 2013/06/29 19:41:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsbsms/libsbsms-2.0.1.ebuild,v 1.8 2015/01/29 17:41:44 mgorny Exp $
EAPI=4
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/sbsms/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips ppc ppc64 x86"
-IUSE="sse static-libs"
+IUSE="cpu_flags_x86_sse static-libs"
src_prepare() {
epatch \
@@ -26,7 +26,7 @@ src_configure() {
econf \
--enable-shared \
$(use_enable static-libs static) \
- $(use_enable sse) \
+ $(use_enable cpu_flags_x86_sse sse) \
--disable-multithreaded
# threaded version causes segfaults
}
diff --git a/media-libs/libsbsms/libsbsms-2.0.2.ebuild b/media-libs/libsbsms/libsbsms-2.0.2.ebuild
index 88a5e35888b8..492609c344f2 100644
--- a/media-libs/libsbsms/libsbsms-2.0.2.ebuild
+++ b/media-libs/libsbsms/libsbsms-2.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsbsms/libsbsms-2.0.2.ebuild,v 1.1 2014/10/10 04:29:01 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsbsms/libsbsms-2.0.2.ebuild,v 1.2 2015/01/29 17:41:44 mgorny Exp $
EAPI=5
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/sbsms/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="sse static-libs"
+IUSE="cpu_flags_x86_sse static-libs"
src_prepare() {
epatch "${FILESDIR}"/${P}-cflags.patch
@@ -24,7 +24,7 @@ src_configure() {
econf \
--enable-shared \
$(use_enable static-libs static) \
- $(use_enable sse) \
+ $(use_enable cpu_flags_x86_sse sse) \
--disable-multithreaded
# threaded version causes segfaults
}