summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/Manifest2
-rw-r--r--games-emulation/stella/files/digest-stella-2.0.11
-rw-r--r--games-emulation/stella/stella-2.0.1.ebuild56
4 files changed, 65 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index d104e3c29432..da051c998a2a 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.15 2005/05/01 18:22:40 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.16 2005/11/16 01:07:55 mr_bones_ Exp $
+
+*stella-2.0.1 (16 Nov 2005)
+
+ 16 Nov 2005; Michael Sterrett <mr_bones_@gentoo.org> +stella-2.0.1.ebuild:
+ version bump
01 May 2005; Michael Hanselmann <hansmi@gentoo.org> stella-1.4.2.ebuild:
Stable on ppc.
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index 983e268caeca..2e6b658b32ad 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1,4 +1,6 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 e863cc9ae62eb20dd3c83e07a15ef6a4 stella-2.0.1.ebuild 1141
MD5 e863cc9ae62eb20dd3c83e07a15ef6a4 stella-1.4.2.ebuild 1141
MD5 b05f4db1ca893808d77e790f0ffbd245 ChangeLog 1978
MD5 bf8549c6a110987d2861afe3d1cbb205 files/digest-stella-1.4.2 68
+MD5 78a370769bf849d9d3b7771e204f6d7a files/digest-stella-2.0.1 69
diff --git a/games-emulation/stella/files/digest-stella-2.0.1 b/games-emulation/stella/files/digest-stella-2.0.1
new file mode 100644
index 000000000000..5edc318f0b9f
--- /dev/null
+++ b/games-emulation/stella/files/digest-stella-2.0.1
@@ -0,0 +1 @@
+MD5 ade7b534db5ff1a1626d51c38ad6d9e1 stella-2.0.1-src.tar.gz 1022969
diff --git a/games-emulation/stella/stella-2.0.1.ebuild b/games-emulation/stella/stella-2.0.1.ebuild
new file mode 100644
index 000000000000..7540abad8e09
--- /dev/null
+++ b/games-emulation/stella/stella-2.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.0.1.ebuild,v 1.1 2005/11/16 01:07:55 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:/etc:${GAMES_SYSCONFDIR}:g" \
+ src/macosx/OSystemMACOSX.cxx \
+ src/unix/OSystemUNIX.cxx \
+ src/unix/stella.spec \
+ src/psp/OSystemPSP.cxx \
+ docs/stella.html \
+ docs/debugger.html \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "/icons/d" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}/${PN}" \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ doicon src/common/stella.xpm
+ make_desktop_entry stella Stella stella.xpm
+ prepgamesdirs
+}