summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/ChangeLog6
-rw-r--r--games-emulation/snes9x/files/snes9x-1.43-porting.patch81
-rw-r--r--games-emulation/snes9x/snes9x-1.43-r1.ebuild8
3 files changed, 91 insertions, 4 deletions
diff --git a/games-emulation/snes9x/ChangeLog b/games-emulation/snes9x/ChangeLog
index 18a1e108f1a2..22912a3fa4af 100644
--- a/games-emulation/snes9x/ChangeLog
+++ b/games-emulation/snes9x/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/snes9x
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.18 2005/08/27 04:51:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.19 2005/08/28 21:17:10 vapier Exp $
+
+ 28 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/snes9x-1.43-porting.patch, snes9x-1.43-r1.ebuild:
+ Add dev support for building for native amd64 #104049.
*snes9x-1.43-r1 (27 Aug 2005)
diff --git a/games-emulation/snes9x/files/snes9x-1.43-porting.patch b/games-emulation/snes9x/files/snes9x-1.43-porting.patch
new file mode 100644
index 000000000000..33d03bbc46e5
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.43-porting.patch
@@ -0,0 +1,81 @@
+http://www.snes9x.com/phpbb2/viewtopic.php?p=12712
+http://bugs.gentoo.org/104049
+
+--- snes9x/configure.in
++++ snes9x/configure.in
+@@ -585,6 +585,19 @@
+ SYSDEFINES="$SYSDEFINES"' -DHAVE_SYS_IOCTL_H'
+ ])
+
++AC_CHECK_HEADER(endian.h, [
++ SYSDEFINES="$SYSDEFINES"' -DHAVE_ENDIAN_H'
++])
++AC_CHECK_HEADER(sys/endian.h, [
++ SYSDEFINES="$SYSDEFINES"' -DHAVE_SYS_ENDIAN_H'
++])
++AC_CHECK_HEADER(machine/endian.h, [
++ SYSDEFINES="$SYSDEFINES"' -DHAVE_MACHINE_ENDIAN_H'
++])
++AC_CHECK_HEADER(sys/isa_defs.h, [
++ SYSDEFINES="$SYSDEFINES"' -DHAVE_SYS_ISA_DEFS_H'
++])
++
+ AC_CHECK_HEADERS(unistd.h sys/socket.h winsock.h winsock2.h WS2tcpip.h)
+
+
+--- snes9x/port.h.orig 2005-08-28 16:57:03.000000000 -0400
++++ snes9x/port.h 2005-08-28 17:11:59.000000000 -0400
+@@ -110,6 +110,19 @@
+
+ #include <sys/types.h>
+
++#if defined(HAVE_ENDIAN_H)
++# include <endian.h>
++#endif
++#if defined(HAVE_SYS_ENDIAN_H)
++# include <sys/endian.h>
++#endif
++#if defined(HAVE_MACHINE_ENDIAN_H)
++# include <machine/endian.h>
++#endif
++#if defined(HAVE_SYS_ISA_DEFS_H)
++# include <sys/isa_defs.h>
++#endif
++
+ /* #define PIXEL_FORMAT RGB565 */
+ #define GFX_MULTI_FORMAT
+
+@@ -265,12 +278,27 @@
+ #define SIG_PF void(*)(int)
+ #endif
+
+-#if defined(__i386__) || defined(__i486__) || defined(__i586__) || \
+- defined(__WIN32__) || defined(__alpha__)
+-#define LSB_FIRST
+-#define FAST_LSB_WORD_ACCESS
+-#else
+-#define MSB_FIRST
++#if defined(BYTE_ORDER)
++# if BYTE_ORDER == LITTLE_ENDIAN
++# define LSB_FIRST
++# else
++# define MSB_FIRST
++# endif
++#elif defined(WORDS_LITTLENDIAN)
++# define LSB_FIRST
++#elif defined(WORDS_BIGENDIAN)
++# define MSB_FIRST
++#else
++# if defined(__i386__) || defined(__i486__) || defined(__i586__) || \
++ defined(__WIN32__) || defined(__alpha__) || defined(__x86_64__)
++# define LSB_FIRST
++# else
++# define MSB_FIRST
++# endif
++#endif
++
++#if defined(LSB_FIRST)
++# define FAST_LSB_WORD_ACCESS
+ #endif
+
+ #ifdef __sun
diff --git a/games-emulation/snes9x/snes9x-1.43-r1.ebuild b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
index b2bf42c2c16e..7c81c1e1cee5 100644
--- a/games-emulation/snes9x/snes9x-1.43-r1.ebuild
+++ b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.1 2005/08/27 04:51:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.2 2005/08/28 21:17:10 vapier Exp $
# 3dfx support (glide) is disabled because it requires
# glide-v2 while we only provide glide-v3 in portage
@@ -31,18 +31,20 @@ src_unpack() {
unpack ${A}
cd "${S}"/snes9x
epatch "${FILESDIR}"/nojoy.patch
+ epatch "${FILESDIR}"/${P}-porting.patch
epatch "${FILESDIR}"/${P}-key-bindings-fix.patch #81980
sed -i 's:png_jmpbuf:png_write_info:g' configure
rm offsets # stupid prebuilt file
sed -i -e 's:-lXext -lX11::' Makefile.in
sed -i -e '/X_LDFLAGS=/d' configure
- cp Makefile.in{,.orig}
epatch "${FILESDIR}"/${P}-build.patch
+
+ autoconf || die
}
src_compile() {
- if use amd64 ; then
+ if use amd64 && [[ -z ${NATIVE_AMD64_BUILD_PLZ} ]] ; then
export ABI=x86
append-flags -m32
append-ldflags -m32