summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog7
-rw-r--r--games-board/crafty/Manifest2
-rw-r--r--games-board/crafty/crafty-19.20.ebuild76
-rw-r--r--games-board/crafty/files/digest-crafty-19.201
4 files changed, 85 insertions, 1 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index 5413b54c6687..0edc3809d9d6 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.13 2005/08/24 05:28:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.14 2005/08/25 00:46:12 mr_bones_ Exp $
+
+*crafty-19.20 (25 Aug 2005)
+
+ 25 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org> +crafty-19.20.ebuild:
+ version bump (bug #103567)
24 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org> -crafty-19.1.ebuild,
-crafty-19.12.ebuild, -crafty-19.15.ebuild, -crafty-19.18.ebuild:
diff --git a/games-board/crafty/Manifest b/games-board/crafty/Manifest
index 1c8cce535962..a96a4bffce58 100644
--- a/games-board/crafty/Manifest
+++ b/games-board/crafty/Manifest
@@ -1,8 +1,10 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 3cab1102bbc9003cdc5c8c934bef76a3 crafty-19.20.ebuild 2279
MD5 3cab1102bbc9003cdc5c8c934bef76a3 crafty-19.19.ebuild 2279
MD5 6cb709392e8c7fd59f475c9d9f67aff5 ChangeLog 2145
MD5 3505ffbd5c4bb22f2789ff8c96979fb6 crafty-19.8.ebuild 2113
MD5 901b6df7332530910e854f501d4d49e1 files/digest-crafty-19.19 64
MD5 4970593053a51ce5e26ea2d6bd89ffe9 files/19.8-ppc.patch 702
+MD5 1d2478ad97099a71745f628650cfa99b files/digest-crafty-19.20 64
MD5 1cfc5524de1fd69ae391d434d6e483d9 files/crafty-18.15-ppc.patch 634
MD5 17996dcbb38db4126094543f36cd43d1 files/digest-crafty-19.8 63
diff --git a/games-board/crafty/crafty-19.20.ebuild b/games-board/crafty/crafty-19.20.ebuild
new file mode 100644
index 000000000000..931f4cb78078
--- /dev/null
+++ b/games-board/crafty/crafty-19.20.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-19.20.ebuild,v 1.1 2005/08/25 00:46:12 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.tar.gz"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="icc no-opts"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ icc? ( >=dev-lang/icc-5.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if use icc ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [ "${CHOST}" == "i686-pc-linux-gnu" ] || [ "${CHOST}" == "i586-pc-linux-gnu" ] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fforce-mem -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="-lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp || die "doins failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo
+ einfo "Note: No books or tablebases have been installed. If you want them, just"
+ einfo " download them from ${HOMEPAGE}."
+ einfo " You will find documentation there too. In most cases you take now "
+ einfo " your xboard compatible application, (xboard, eboard, knights) and "
+ einfo " just play chess against computer opponent. Have fun."
+ einfo
+}
diff --git a/games-board/crafty/files/digest-crafty-19.20 b/games-board/crafty/files/digest-crafty-19.20
new file mode 100644
index 000000000000..ab7188b8e9b6
--- /dev/null
+++ b/games-board/crafty/files/digest-crafty-19.20
@@ -0,0 +1 @@
+MD5 7fb0c06b5f437ba2920ed5d2b4c9f3ca crafty-19.20.tar.gz 404648