summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/distutils.eclass')
-rw-r--r--eclass/distutils.eclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index 31f9f083d026..4ad5bceb481c 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.51 2008/06/28 00:05:40 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.52 2008/09/24 16:45:08 hawking Exp $
# @ECLASS: distutils.eclass
# @MAINTAINER:
@@ -71,9 +71,11 @@ distutils_src_install() {
[ -n "${pylibdir}" ] && dodir "${pylibdir}"
if has_version ">=dev-lang/python-2.3"; then
- ${python} setup.py install --root=${D} --no-compile "$@" || die
+ ${python} setup.py install --root="${D}" --no-compile "$@" ||\
+ die "python setup.py install failed"
else
- ${python} setup.py install --root=${D} "$@" || die
+ ${python} setup.py install --root="${D}" "$@" ||\
+ die "python setup.py install failed"
fi
DDOCS="CHANGELOG KNOWN_BUGS MAINTAINERS PKG-INFO CONTRIBUTORS TODO NEWS"