summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tcllib/tcllib-1.11.ebuild')
-rw-r--r--dev-tcltk/tcllib/tcllib-1.11.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-tcltk/tcllib/tcllib-1.11.ebuild b/dev-tcltk/tcllib/tcllib-1.11.ebuild
new file mode 100644
index 000000000000..73c89b2b88ba
--- /dev/null
+++ b/dev-tcltk/tcllib/tcllib-1.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcllib/tcllib-1.11.ebuild,v 1.1 2008/10/26 11:35:16 mescalinum Exp $
+
+DESCRIPTION="Tcl Standard Library."
+HOMEPAGE="http://www.tcl.tk/software/tcllib/"
+SRC_URI="mirror://sourceforge/tcllib/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~s390 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=dev-lang/tcl-8.4"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog DESCRIPTION.txt README* STATUS devdoc/*.txt
+ dohtml devdoc/*.html
+ if use examples ; then
+ for f in $(find examples -type f); do
+ docinto $(dirname $f)
+ dodoc $f
+ done
+ fi
+}