summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile/guile-1.8.1.ebuild')
-rw-r--r--dev-scheme/guile/guile-1.8.1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-scheme/guile/guile-1.8.1.ebuild b/dev-scheme/guile/guile-1.8.1.ebuild
deleted file mode 100644
index d61cecb9bfc4..000000000000
--- a/dev-scheme/guile/guile-1.8.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.1.ebuild,v 1.1 2007/01/22 18:24:37 hkbst Exp $
-
-inherit autotools
-
-DESCRIPTION="Scheme interpreter"
-HOMEPAGE="http://www.gnu.org/software/guile/"
-SRC_URI="mirror://gnu/guile/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-DEPEND=">=dev-libs/gmp-4.1
- >=sys-devel/libtool-1.5.6"
-
-# Guile seems to contain some slotting support, /usr/share/guile/ is slotted, but there are lots of collisions. Most in /usr/share/libguile. Therefore I'm slotting this in the same slot as guile-1.6* for now.
-SLOT="12"
-MAJOR="1.8"
-
-IUSE="networking regex discouraged deprecated elisp nls debug-freelist debug-malloc debug threads"
-
-src_compile() {
-#will fail for me if posix is disabled or without modules -- hkBst
- econf \
- --disable-error-on-warning
- --disable-static \
- --enable-posix \
- $(use_enable networking) \
- $(use_enable regex) \
- $(use_enable discouraged) \
- $(use_enable deprecated) \
- $(use_enable elisp) \
- $(use_enable nls) \
- --disable-rpath \
- $(use_enable debug-freelist) \
- $(use_enable debug-malloc) \
- $(use_enable debug guile-debug) \
- $(use_with threads) \
- --with-modules
-
- emake || die "make failed"
-}
-
-src_install() {
- einstall || die "install failed"
-
- dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
-
- # texmacs needs this, closing bug #23493
- dodir /etc/env.d
- echo "GUILE_LOAD_PATH=\"/usr/share/guile/${MAJOR}\"" > ${D}/etc/env.d/50guile
-} \ No newline at end of file