summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile-gnome-platform/files/2.15.92-add-cairo-fix-from-bzr.patch')
-rw-r--r--dev-scheme/guile-gnome-platform/files/2.15.92-add-cairo-fix-from-bzr.patch91
1 files changed, 91 insertions, 0 deletions
diff --git a/dev-scheme/guile-gnome-platform/files/2.15.92-add-cairo-fix-from-bzr.patch b/dev-scheme/guile-gnome-platform/files/2.15.92-add-cairo-fix-from-bzr.patch
new file mode 100644
index 000000000000..030e5c1229d7
--- /dev/null
+++ b/dev-scheme/guile-gnome-platform/files/2.15.92-add-cairo-fix-from-bzr.patch
@@ -0,0 +1,91 @@
+=== modified file 'ChangeLog'
+--- ChangeLog 2007-05-24 15:14:46 +0000
++++ ChangeLog 2007-05-25 15:49:00 +0000
+@@ -1,3 +1,16 @@
++2007-05-25 Andy Wingo <wingo@pobox.com>
++
++ * gnome/gw/cairo-spec.scm: Now that we are actually making a
++ shlib, init guile-cairo in the shlib instead of in every dependant
++ wrapset.
++
++ * gnome/gw/Makefile.am: I tried really hard to avoid making a
++ shared library for this g-wrap wrapset, since it is not necessary
++ at all, but I have failed for the moment: other wrapsets depending
++ on this one will check to see that something has registered the
++ "guile-cairo" wrapset with the C g-wrap runtime, which will fail
++ unless we actually have a shlib that registers the wrapset. Suck.
++
+ 2007-05-24 Andy Wingo <wingo@pobox.com>
+
+ * == Released guile-gnome-platform version 2.15.92 ==
+
+=== modified file 'gnome/gw/Makefile.am'
+--- gnome/gw/Makefile.am 2007-05-20 17:43:35 +0000
++++ gnome/gw/Makefile.am 2007-05-25 15:49:00 +0000
+@@ -1,5 +1,27 @@
+ include $(top_srcdir)/common.mk
+
+-guilegwmodule_DATA = cairo-spec.scm
++guilegwmodule_DATA = cairo-spec.scm cairo.scm
+
+ EXTRA_DIST = cairo-spec.scm
++
++CLEANFILES = $(wildcard gnome-*.log)
++
++# I wanted to avoid having a cairo shlib, because there is no need, but
++# fighting g-wrap is too difficult for the moment.
++
++guilegnomelib_LTLIBRARIES = libgw-guile-gnome-cairo.la
++
++########################################################################
++## cairo
++nodist_libgw_guile_gnome_cairo_la_SOURCES = guile-gnome-gw-cairo.c
++
++libgw_guile_gnome_cairo_la_CFLAGS = $(GUILE_GLIB_CFLAGS) $(GLIB_CFLAGS) \
++ $(AM_CFLAGS) $(GUILE_CAIRO_CFLAGS) $(GUILE_CFLAGS) \
++ $(G_WRAP_CFLAGS)
++libgw_guile_gnome_cairo_la_LIBADD = $(GUILE_CAIRO_LIBS) $(GUILE_LIBS) \
++ $(G_WRAP_LIBS) $(GUILE_GLIB_LIBS)
++libgw_guile_gnome_cairo_la_LDFLAGS = -module
++
++CLEANFILES += $(wildcard guile-gnome-gw-cairo.*) cairo.scm
++
++BUILT_SOURCES = guile-gnome-gw-cairo.c
+
+=== modified file 'gnome/gw/cairo-spec.scm'
+--- gnome/gw/cairo-spec.scm 2007-05-20 22:39:45 +0000
++++ gnome/gw/cairo-spec.scm 2007-05-25 15:49:00 +0000
+@@ -27,7 +27,7 @@
+ (define-module (gnome gw cairo-spec)
+ #:use-module (oop goops)
+ #:use-module (gnome gw support g-wrap)
+- #:use-module (gnome gw support defs)
++ #:use-module (gnome gw gobject-spec)
+ #:use-module (gnome gw support gobject))
+
+ ;; G-Wrap inelegance
+@@ -116,8 +116,6 @@
+ (define-class <client-actions> (<gw-item>))
+ (define-method (global-declarations-cg (ws <gw-guile-wrapset>) (a <client-actions>))
+ '("#include <guile-cairo.h>\n"))
+-(define-method (initializations-cg (wrapset <gw-guile-wrapset>) (a <client-actions>) err)
+- (list "scm_init_cairo ();\n"))
+
+ (define-class <cairo-wrapset> (<gobject-wrapset-base>)
+ #:id 'gnome-cairo
+@@ -144,6 +142,14 @@
+ #:take "scm_take_cairo_font_options"))
+ (add-type-alias! ws "cairo_font_options_t*" 'cairo-font-options-t))
+
++(define-method (global-declarations-cg (ws <cairo-wrapset>))
++ (list (next-method)
++ "#include <guile-cairo.h>\n"))
++
++(define-method (initializations-cg (wrapset <cairo-wrapset>) err)
++ (list (next-method)
++ "scm_init_cairo ();\n"))
++
+ ;; pango-cairo
+ ;; cairo_t, cairo_font_options_t
+
+