summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/text-format')
-rw-r--r--dev-ruby/text-format/ChangeLog12
-rw-r--r--dev-ruby/text-format/text-format-1.0.0-r1.ebuild4
-rw-r--r--dev-ruby/text-format/text-format-1.0.0-r2.ebuild28
3 files changed, 41 insertions, 3 deletions
diff --git a/dev-ruby/text-format/ChangeLog b/dev-ruby/text-format/ChangeLog
index db04367d81d6..b7b9b6a347ad 100644
--- a/dev-ruby/text-format/ChangeLog
+++ b/dev-ruby/text-format/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-ruby/text-format
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/ChangeLog,v 1.35 2010/05/23 10:15:38 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/ChangeLog,v 1.36 2010/08/01 18:29:42 flameeyes Exp $
+
+ 01 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ text-format-1.0.0-r1.ebuild, +text-format-1.0.0-r2.ebuild:
+ Move non-ruby18 support to a new revision to mark one stable.
+
+*text-format-1.0.0-r2 (01 Aug 2010)
+
+ 01 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +text-format-1.0.0-r2.ebuild:
+ Move non-ruby18 support to a new revision to mark one stable.
23 May 2010; Alex Legler <a3li@gentoo.org> text-format-1.0.0-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/text-format/text-format-1.0.0-r1.ebuild b/dev-ruby/text-format/text-format-1.0.0-r1.ebuild
index 9ea1a64ab45e..31dc19296ce8 100644
--- a/dev-ruby/text-format/text-format-1.0.0-r1.ebuild
+++ b/dev-ruby/text-format/text-format-1.0.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/text-format-1.0.0-r1.ebuild,v 1.6 2010/05/23 10:15:38 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/text-format-1.0.0-r1.ebuild,v 1.7 2010/08/01 18:29:42 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README Changelog ToDo"
diff --git a/dev-ruby/text-format/text-format-1.0.0-r2.ebuild b/dev-ruby/text-format/text-format-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..f9e52a9b94ff
--- /dev/null
+++ b/dev-ruby/text-format/text-format-1.0.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/text-format-1.0.0-r2.ebuild,v 1.1 2010/08/01 18:29:42 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README Changelog ToDo"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Text::Format provides strong text formatting capabilities to Ruby"
+HOMEPAGE="http://rubyforge.org/projects/text-format/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/text-hyphen-1.0.0'
+ruby_add_bdepend test 'dev-ruby/archive-tar-minitar'
+
+all_ruby_prepare() {
+ # Fix rakefile for new rake versions
+ sed -i -e 's: if t\.verbose::' Rakefile || die
+}