summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog8
-rw-r--r--dev-ruby/json/json-1.4.6-r1.ebuild67
-rw-r--r--dev-ruby/json/json-1.4.6.ebuild4
3 files changed, 76 insertions, 3 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index bd6114991c0c..3ff8099819ea 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.47 2010/10/31 08:28:41 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.48 2010/10/31 08:37:18 graaff Exp $
+
+*json-1.4.6-r1 (31 Oct 2010)
+
+ 31 Oct 2010; Hans de Graaff <graaff@gentoo.org> json-1.4.6.ebuild,
+ +json-1.4.6-r1.ebuild:
+ Bump revision with ruby19 and create a stable candidate without it.
31 Oct 2010; Hans de Graaff <graaff@gentoo.org> -json-1.4.3-r2.ebuild:
Remove old version.
diff --git a/dev-ruby/json/json-1.4.6-r1.ebuild b/dev-ruby/json/json-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..a5e0c40b37aa
--- /dev/null
+++ b/dev-ruby/json/json-1.4.6-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.6-r1.ebuild,v 1.1 2010/10/31 08:37:18 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension."
+HOMEPAGE="http://json.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ # And use rdoc instead of sdoc which we don't have packaged
+ sed -i \
+ -e 's| => :compile_ext||' \
+ -e 's| => :clean||' \
+ -e 's|sdoc|rdoc|' \
+ Rakefile || die "rakefile fix failed"
+}
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake compile_ext || die "extension compile failed"
+ fi
+}
+
+each_ruby_test() {
+ # We have to set RUBYLIB because otherwise the tests will run
+ # against the sytem-installed json; at the same time, we cannot
+ # use the -I parameter because rake won't let it pass to the
+ # testrb call that is executed down the road.
+
+ RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
+ ${RUBY} -S rake test_pure || die "pure ruby tests failed"
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext" \
+ ${RUBY} -Ilib:ext -S rake test_ext || die " ruby extension tests failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
+ ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
+ fi
+}
diff --git a/dev-ruby/json/json-1.4.6.ebuild b/dev-ruby/json/json-1.4.6.ebuild
index e11890cb735c..26b7b3e4d389 100644
--- a/dev-ruby/json/json-1.4.6.ebuild
+++ b/dev-ruby/json/json-1.4.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.6.ebuild,v 1.2 2010/10/10 13:06:44 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.6.ebuild,v 1.3 2010/10/31 08:37:18 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"