summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog7
-rw-r--r--dev-python/wxpython/files/digest-wxpython-2.4.2.4-r33
-rw-r--r--dev-python/wxpython/files/digest-wxpython-2.4.2.4-r43
-rw-r--r--dev-python/wxpython/files/wxpython-2.4.2.4-64bit.patch58
-rw-r--r--dev-python/wxpython/wxpython-2.4.2.4-r3.ebuild134
-rw-r--r--dev-python/wxpython/wxpython-2.4.2.4-r4.ebuild141
6 files changed, 6 insertions, 340 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 449954b77afa..80edb7835171 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.53 2007/04/07 02:43:07 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.54 2007/04/29 04:05:13 dirtyepic Exp $
+
+ 29 Apr 2007; Ryan Hill <dirtyepic@gentoo.org>
+ -files/wxpython-2.4.2.4-64bit.patch, -wxpython-2.4.2.4-r3.ebuild,
+ -wxpython-2.4.2.4-r4.ebuild:
+ Remove wxpython-2.4 from the tree. Bug #146073.
07 Apr 2007; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.3.3.ebuild:
When USE="opengl" make sure wxGTK was built with opengl support.
diff --git a/dev-python/wxpython/files/digest-wxpython-2.4.2.4-r3 b/dev-python/wxpython/files/digest-wxpython-2.4.2.4-r3
deleted file mode 100644
index 3fa7e90407ac..000000000000
--- a/dev-python/wxpython/files/digest-wxpython-2.4.2.4-r3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ea4eb68e10a0c2a9be643b35dcb78e41 wxPythonSrc-2.4.2.4.tar.gz 13130195
-RMD160 f00398193193f4788e82103e68020a574ac6de5b wxPythonSrc-2.4.2.4.tar.gz 13130195
-SHA256 ae64f838adefe109905e3fbd6b656d088cf6ae9732131893bafc03198edb563a wxPythonSrc-2.4.2.4.tar.gz 13130195
diff --git a/dev-python/wxpython/files/digest-wxpython-2.4.2.4-r4 b/dev-python/wxpython/files/digest-wxpython-2.4.2.4-r4
deleted file mode 100644
index 3fa7e90407ac..000000000000
--- a/dev-python/wxpython/files/digest-wxpython-2.4.2.4-r4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ea4eb68e10a0c2a9be643b35dcb78e41 wxPythonSrc-2.4.2.4.tar.gz 13130195
-RMD160 f00398193193f4788e82103e68020a574ac6de5b wxPythonSrc-2.4.2.4.tar.gz 13130195
-SHA256 ae64f838adefe109905e3fbd6b656d088cf6ae9732131893bafc03198edb563a wxPythonSrc-2.4.2.4.tar.gz 13130195
diff --git a/dev-python/wxpython/files/wxpython-2.4.2.4-64bit.patch b/dev-python/wxpython/files/wxpython-2.4.2.4-64bit.patch
deleted file mode 100644
index d2e6c792daa8..000000000000
--- a/dev-python/wxpython/files/wxpython-2.4.2.4-64bit.patch
+++ /dev/null
@@ -1,58 +0,0 @@
---- wxPythonSrc-2.4.2.4/wxPython/src/gtk/html.cpp~ 2003-06-25 22:35:44.000000000 +0100
-+++ wxPythonSrc-2.4.2.4/wxPython/src/gtk/html.cpp 2006-01-05 17:50:12.000000000 +0000
-@@ -4198,7 +4198,7 @@
- int _arg1 = (int ) -1;
- wxPoint * _arg2 = (wxPoint *) &wxDefaultPosition;
- wxSize * _arg3 = (wxSize *) &wxDefaultSize;
-- int _arg4 = (int ) (wxHW_SCROLLBAR_AUTO);
-+ long _arg4 = (long ) (wxHW_SCROLLBAR_AUTO);
- wxString * _arg5 = (wxString *) &wxPyHtmlWindowNameStr;
- PyObject * _argo0 = 0;
- wxPoint temp;
-@@ -4210,7 +4210,7 @@
- char _ptemp[128];
-
- self = self;
-- if(!PyArg_ParseTupleAndKeywords(args,kwargs,"O|iOOiO:new_wxHtmlWindow",_kwnames,&_argo0,&_arg1,&_obj2,&_obj3,&_arg4,&_obj5))
-+ if(!PyArg_ParseTupleAndKeywords(args,kwargs,"O|iOOlO:new_wxHtmlWindow",_kwnames,&_argo0,&_arg1,&_obj2,&_obj3,&_arg4,&_obj5))
- return NULL;
- if (_argo0) {
- if (_argo0 == Py_None) { _arg0 = NULL; }
-@@ -4292,7 +4292,7 @@
- int _arg2 = (int ) -1;
- wxPoint * _arg3 = (wxPoint *) &wxDefaultPosition;
- wxSize * _arg4 = (wxSize *) &wxDefaultSize;
-- int _arg5 = (int ) (wxHW_SCROLLBAR_AUTO);
-+ long _arg5 = (long ) (wxHW_SCROLLBAR_AUTO);
- wxString * _arg6 = (wxString *) &wxPyHtmlWindowNameStr;
- PyObject * _argo0 = 0;
- PyObject * _argo1 = 0;
-@@ -4304,7 +4304,7 @@
- char *_kwnames[] = { "self","parent","id","pos","size","style","name", NULL };
-
- self = self;
-- if(!PyArg_ParseTupleAndKeywords(args,kwargs,"OO|iOOiO:wxHtmlWindow_Create",_kwnames,&_argo0,&_argo1,&_arg2,&_obj3,&_obj4,&_arg5,&_obj6))
-+ if(!PyArg_ParseTupleAndKeywords(args,kwargs,"OO|iOOlO:wxHtmlWindow_Create",_kwnames,&_argo0,&_argo1,&_arg2,&_obj3,&_obj4,&_arg5,&_obj6))
- return NULL;
- if (_argo0) {
- if (_argo0 == Py_None) { _arg0 = NULL; }
---- wxPythonSrc-2.4.2.4/wxPython/src/gtk/misc2.cpp~ 2003-06-25 22:35:35.000000000 +0100
-+++ wxPythonSrc-2.4.2.4/wxPython/src/gtk/misc2.cpp 2006-01-05 17:50:44.000000000 +0000
-@@ -943,7 +943,7 @@
- int _result;
- wxString * _arg0;
- wxString * _arg1 = (wxString *) &wxPyEmptyString;
-- int _arg2 = (int ) wxOK|wxCENTRE;
-+ long _arg2 = (long ) wxOK|wxCENTRE;
- wxWindow * _arg3 = (wxWindow *) NULL;
- int _arg4 = (int ) -1;
- int _arg5 = (int ) -1;
-@@ -953,7 +953,7 @@
- char *_kwnames[] = { "message","caption","style","parent","x","y", NULL };
-
- self = self;
-- if(!PyArg_ParseTupleAndKeywords(args,kwargs,"O|OiOii:wxMessageBox",_kwnames,&_obj0,&_obj1,&_arg2,&_argo3,&_arg4,&_arg5))
-+ if(!PyArg_ParseTupleAndKeywords(args,kwargs,"O|OlOii:wxMessageBox",_kwnames,&_obj0,&_obj1,&_arg2,&_argo3,&_arg4,&_arg5))
- return NULL;
- {
- _arg0 = wxString_in_helper(_obj0);
diff --git a/dev-python/wxpython/wxpython-2.4.2.4-r3.ebuild b/dev-python/wxpython/wxpython-2.4.2.4-r3.ebuild
deleted file mode 100644
index 840cfeed9837..000000000000
--- a/dev-python/wxpython/wxpython-2.4.2.4-r3.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.4.2.4-r3.ebuild,v 1.3 2007/01/05 22:12:48 dirtyepic Exp $
-
-inherit eutils wxwidgets python multilib
-
-MY_P="${P/wxpython-/wxPythonSrc-}"
-S="${WORKDIR}/${MY_P}/wxPython"
-DESCRIPTION="A blending of the wxWindows C++ class library with Python"
-HOMEPAGE="http://www.wxpython.org/"
-SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.gz"
-
-LICENSE="wxWinLL-3"
-SLOT="2.4"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
-IUSE="gtk gtk2 unicode opengl tiff jpeg png"
-
-RDEPEND=">=dev-lang/python-2.1
- =x11-libs/wxGTK-2.4.2*
- gtk2? ( >=x11-libs/gtk+-2.0
- >=x11-libs/pango-1.2
- >=dev-libs/glib-2.0 )
- unicode? ( >=x11-libs/gtk+-2.0
- >=x11-libs/pango-1.2
- >=dev-libs/glib-2.0 )
- !gtk2? ( =x11-libs/gtk+-1.2*
- =dev-libs/glib-1.2* )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- tiff? ( media-libs/tiff )
- >=sys-libs/zlib-1.1.4
- opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
-
-DEPEND="${RDEPEND}
- gtk2? ( dev-util/pkgconfig )"
-
-pkg_setup() {
- if use unicode; then
- ! use gtk2 && die "You must put gtk2 in your USE if you need unicode support"
- fi
-}
-
-src_compile() {
- local mypyconf
-
- if ! use gtk2; then
- need-wxwidgets gtk || die "Emerge wxGTK with wxgtk1 in USE"
- elif use unicode; then
- need-wxwidgets unicode || die "Emerge wxGTK with unicode in USE"
- else
- need-wxwidgets gtk2 || die "Emerge wxGTK with gtk2 in USE"
- fi
-
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
-
- use gtk2 \
- && mypyconf="${mypyconf} WXPORT=gtk2" \
- || mypyconf="${mypyconf} WXPORT=gtk"
-
- use unicode && mypyconf="${mypyconf} UNICODE=1"
-
- python setup.py ${mypyconf} build || die "build failed"
-}
-
-src_install() {
- python_version
- local mypyconf
- local dest
- local wx_name
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
- use gtk2 \
- && mypyconf="${mypyconf} WXPORT=gtk2" \
- || mypyconf="${mypyconf} WXPORT=gtk"
- use unicode && mypyconf="${mypyconf} UNICODE=1"
-
-
- # This can all be removed when 2.4.3 is released:
- # Future: Make sure we don't clobber existing wxversion.py or wx.pth
- # from SLOT'd versions.
- if use unicode; then
- wx_name=wx-${PV:0:3}-gtk2-unicode
- elif use gtk2; then
- wx_name=wx-${PV:0:3}-gtk2-ansi
- else
- wx_name=wx-${PV:0:3}-gtk-ansi
- fi
- dest=${site_pkgs}/${wx_name}
- dodir ${site_pkgs}
- dodir ${dest}
-
- python setup.py ${mypyconf} install --prefix=/usr \
- --install-lib=${dest} --root=${D} || die
-
- echo ${wx_name} > ${D}/${site_pkgs}/wx.pth || \
- die "Couldn't create wx.pth"
- elog "Setting ${wx_name} as system default wxPython"
- echo ${wx_name} > ${D}/${site_pkgs}/wx.pth || \
- die "Couldn't create wx.pth"
-
- cp ${FILESDIR}/wxversion.py ${D}/${site_pkgs} || \
- die "Couldn't copy wxversion.py"
- dodir ${site_pkgs}
-
- cp ${FILESDIR}/wxpy-config.py ${D}/${site_pkgs}/ || \
- die "Couldn't copy wxpy-config.py"
-}
-
-pkg_postinst() {
-
- elog "Gentoo now uses the Multi-version method for SLOT'ing"
- elog "Developers see this site for instructions on using 2.4 or 2.6"
- elog "with your apps:"
- elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
-}
-
-pkg_postrm() {
- python_version
- site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
- cd ${site_pkgs}
- #If 2.4 is removed, set 2.6 as default version:
- for wxver in "wx-2.6-gtk2-unicode" "wx-2.6-gtk2-ansi" "wx-2.6-gtk"
- do
- if [ -e "${wxver}" ]; then
- echo "Setting ${wxver} as system default."
- echo "${wxver}" > "wx.pth"
- fi
- done
-}
diff --git a/dev-python/wxpython/wxpython-2.4.2.4-r4.ebuild b/dev-python/wxpython/wxpython-2.4.2.4-r4.ebuild
deleted file mode 100644
index aefb35861e35..000000000000
--- a/dev-python/wxpython/wxpython-2.4.2.4-r4.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.4.2.4-r4.ebuild,v 1.1 2007/02/03 15:18:32 blubb Exp $
-
-inherit eutils wxwidgets python multilib
-
-MY_P="${P/wxpython-/wxPythonSrc-}"
-S="${WORKDIR}/${MY_P}/wxPython"
-DESCRIPTION="A blending of the wxWindows C++ class library with Python"
-HOMEPAGE="http://www.wxpython.org/"
-SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.gz"
-
-LICENSE="wxWinLL-3"
-SLOT="2.4"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="gtk gtk2 unicode opengl tiff jpeg png"
-
-RDEPEND=">=dev-lang/python-2.1
- =x11-libs/wxGTK-2.4.2*
- gtk2? ( >=x11-libs/gtk+-2.0
- >=x11-libs/pango-1.2
- >=dev-libs/glib-2.0 )
- unicode? ( >=x11-libs/gtk+-2.0
- >=x11-libs/pango-1.2
- >=dev-libs/glib-2.0 )
- !gtk2? ( =x11-libs/gtk+-1.2*
- =dev-libs/glib-1.2* )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- tiff? ( media-libs/tiff )
- >=sys-libs/zlib-1.1.4
- opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
-
-DEPEND="${RDEPEND}
- gtk2? ( dev-util/pkgconfig )"
-
-pkg_setup() {
- if use unicode; then
- ! use gtk2 && die "You must put gtk2 in your USE if you need unicode support"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch "${FILESDIR}"/${P}-64bit.patch
-}
-
-src_compile() {
- local mypyconf
-
- if ! use gtk2; then
- need-wxwidgets gtk || die "Emerge wxGTK with wxgtk1 in USE"
- elif use unicode; then
- need-wxwidgets unicode || die "Emerge wxGTK with unicode in USE"
- else
- need-wxwidgets gtk2 || die "Emerge wxGTK with gtk2 in USE"
- fi
-
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
-
- use gtk2 \
- && mypyconf="${mypyconf} WXPORT=gtk2" \
- || mypyconf="${mypyconf} WXPORT=gtk"
-
- use unicode && mypyconf="${mypyconf} UNICODE=1"
-
- python setup.py ${mypyconf} build || die "build failed"
-}
-
-src_install() {
- python_version
- local mypyconf
- local dest
- local wx_name
- local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
-
- use opengl \
- && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
- || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
- use gtk2 \
- && mypyconf="${mypyconf} WXPORT=gtk2" \
- || mypyconf="${mypyconf} WXPORT=gtk"
- use unicode && mypyconf="${mypyconf} UNICODE=1"
-
-
- # This can all be removed when 2.4.3 is released:
- # Future: Make sure we don't clobber existing wxversion.py or wx.pth
- # from SLOT'd versions.
- if use unicode; then
- wx_name=wx-${PV:0:3}-gtk2-unicode
- elif use gtk2; then
- wx_name=wx-${PV:0:3}-gtk2-ansi
- else
- wx_name=wx-${PV:0:3}-gtk-ansi
- fi
- dest=${site_pkgs}/${wx_name}
- dodir ${site_pkgs}
- dodir ${dest}
-
- python setup.py ${mypyconf} install --prefix=/usr \
- --install-lib=${dest} --root=${D} || die
-
- echo ${wx_name} > ${D}/${site_pkgs}/wx.pth || \
- die "Couldn't create wx.pth"
- elog "Setting ${wx_name} as system default wxPython"
- echo ${wx_name} > ${D}/${site_pkgs}/wx.pth || \
- die "Couldn't create wx.pth"
-
- cp ${FILESDIR}/wxversion.py ${D}/${site_pkgs} || \
- die "Couldn't copy wxversion.py"
- dodir ${site_pkgs}
-
- cp ${FILESDIR}/wxpy-config.py ${D}/${site_pkgs}/ || \
- die "Couldn't copy wxpy-config.py"
-}
-
-pkg_postinst() {
-
- elog "Gentoo now uses the Multi-version method for SLOT'ing"
- elog "Developers see this site for instructions on using 2.4 or 2.6"
- elog "with your apps:"
- elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
-}
-
-pkg_postrm() {
- python_version
- site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
- cd ${site_pkgs}
- #If 2.4 is removed, set 2.6 as default version:
- for wxver in "wx-2.6-gtk2-unicode" "wx-2.6-gtk2-ansi" "wx-2.6-gtk"
- do
- if [ -e "${wxver}" ]; then
- echo "Setting ${wxver} as system default."
- echo "${wxver}" > "wx.pth"
- fi
- done
-}