summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/ChangeLog7
-rw-r--r--dev-python/stevedore/stevedore-0.8-r1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/stevedore/ChangeLog b/dev-python/stevedore/ChangeLog
index 9f68863926f0..be4abd2f2f7f 100644
--- a/dev-python/stevedore/ChangeLog
+++ b/dev-python/stevedore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/stevedore
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.2 2013/01/26 05:41:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.3 2013/04/19 07:39:32 idella4 Exp $
+
+*stevedore-0.8-r1 (19 Apr 2013)
+
+ 19 Apr 2013; Ian Delaney <idella4@gentoo.org> +stevedore-0.8-r1.ebuild:
+ migration -> distutils-r1
*stevedore-0.8 (26 Jan 2013)
diff --git a/dev-python/stevedore/stevedore-0.8-r1.ebuild b/dev-python/stevedore/stevedore-0.8-r1.ebuild
new file mode 100644
index 000000000000..c6eb2530101f
--- /dev/null
+++ b/dev-python/stevedore/stevedore-0.8-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.8-r1.ebuild,v 1.1 2013/04/19 07:39:32 idella4 Exp $
+
+EAPI=5
+
+# pypy may not be required, but nor does it bring any harm
+PYTHON_COMPAT=( python{2_6,2_7,3_2} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/dreamhost/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r docs/build/html/
+}