summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycurl/pycurl-7.15.1.ebuild')
-rw-r--r--dev-python/pycurl/pycurl-7.15.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycurl/pycurl-7.15.1.ebuild b/dev-python/pycurl/pycurl-7.15.1.ebuild
new file mode 100644
index 000000000000..e11487a0b9ed
--- /dev/null
+++ b/dev-python/pycurl/pycurl-7.15.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.15.1.ebuild,v 1.1 2006/02/23 09:01:19 lucass Exp $
+
+inherit distutils
+
+DESCRIPTION="python binding for curl/libcurl"
+HOMEPAGE="http://pycurl.sourceforge.net/"
+SRC_URI="http://pycurl.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/python
+ >=net-misc/curl-${PV}"
+
+PYTHON_MODNAME="curl"
+
+src_install(){
+ DOCS="TODO"
+ distutils_src_install
+ mv ${D}/usr/share/doc/pycurl/examples ${D}/usr/share/doc/${PF}
+ mv ${D}/usr/share/doc/pycurl/html ${D}/usr/share/doc/${PF}
+ mv ${D}/usr/share/doc/pycurl/tests ${D}/usr/share/doc/${PF}
+ rm -fr ${D}/usr/share/doc/pycurl
+}