summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/ChangeLog11
-rw-r--r--dev-python/libvirt-python/libvirt-python-1.2.0.ebuild43
-rw-r--r--dev-python/libvirt-python/metadata.xml5
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/ChangeLog b/dev-python/libvirt-python/ChangeLog
new file mode 100644
index 000000000000..4f6555c009c5
--- /dev/null
+++ b/dev-python/libvirt-python/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/libvirt-python
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/ChangeLog,v 1.1 2013/12/02 22:40:24 cardoe Exp $
+
+*libvirt-python-1.2.0 (02 Dec 2013)
+
+ 02 Dec 2013; Doug Goldstein <cardoe@gentoo.org> +libvirt-python-1.2.0.ebuild,
+ +metadata.xml:
+ Initial version of the Python bindings for libvirt that are now split from the
+ main libvirt repo. This also allows us to build the bindings against multiple
+ versions of Python.
diff --git a/dev-python/libvirt-python/libvirt-python-1.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-1.2.0.ebuild
new file mode 100644
index 000000000000..05afa9302c2f
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-1.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/libvirt-python-1.2.0.ebuild,v 1.1 2013/12/02 22:40:24 cardoe Exp $
+
+EAPI=5
+
+#BACKPORTS=062ad8b2
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz
+ ${BACKPORTS:+
+ http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-0.9.6:=[-python(-)]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml )"
+
+S="${WORKDIR}/${P%_rc*}"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/libvirt-python/metadata.xml b/dev-python/libvirt-python/metadata.xml
new file mode 100644
index 000000000000..cd1013a67bf6
--- /dev/null
+++ b/dev-python/libvirt-python/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>virtualization</herd>
+</pkgmetadata>