summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/ChangeLog7
-rw-r--r--dev-python/alembic/alembic-0.6.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/alembic/ChangeLog b/dev-python/alembic/ChangeLog
index bd5fc2057ea8..14f91cbc64b9 100644
--- a/dev-python/alembic/ChangeLog
+++ b/dev-python/alembic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/alembic
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/ChangeLog,v 1.6 2013/10/21 13:23:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/ChangeLog,v 1.7 2013/10/22 03:05:48 yac Exp $
+
+*alembic-0.6.0 (22 Oct 2013)
+
+ 22 Oct 2013; Jan Matejka <yac@gentoo.org> +alembic-0.6.0.ebuild:
+ verbump with python 3.3 support, refs 488862
21 Oct 2013; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Fix e-mail address.
diff --git a/dev-python/alembic/alembic-0.6.0.ebuild b/dev-python/alembic/alembic-0.6.0.ebuild
new file mode 100644
index 000000000000..aeb4ce4dd02b
--- /dev/null
+++ b/dev-python/alembic/alembic-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/alembic-0.6.0.ebuild,v 1.1 2013/10/22 03:05:48 yac Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+RDEPEND=">=dev-python/sqlalchemy-0.7.9
+ dev-python/mako
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ cp -r test.cfg tests "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 -w -n tests || die
+ fi
+ nosetests || die "Testing failed with ${EPYTHON}"
+}