summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/lua/lua-4.0.ebuild')
-rw-r--r--dev-lang/lua/lua-4.0.ebuild34
1 files changed, 18 insertions, 16 deletions
diff --git a/dev-lang/lua/lua-4.0.ebuild b/dev-lang/lua/lua-4.0.ebuild
index 4a330465761e..fdb8136873e9 100644
--- a/dev-lang/lua/lua-4.0.ebuild
+++ b/dev-lang/lua/lua-4.0.ebuild
@@ -1,19 +1,21 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Larry Cow <larrycow@free.fr>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-4.0.ebuild,v 1.1 2002/04/25 01:57:00 rphillips Exp $
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-4.0.ebuild,v 1.1.1.1 2005/11/30 09:58:04 chriswhite Exp $
-P="lua"
-S=${WORKDIR}/${P}
+inherit eutils
+
+S=${WORKDIR}/lua
DESCRIPTION="A powerful light-weight programming language designed for extending applications."
-SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+SRC_URI="http://www.lua.org/ftp/${PN}.tar.gz"
HOMEPAGE="http://www.lua.org/"
-
-DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc"
+IUSE=""
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+LICENSE="lua"
+DEPEND="virtual/libc"
src_compile() {
- patch < ${FILESDIR}/lua-4.0-config.patch
+ epatch ${FILESDIR}/lua-4.0-config.patch
emake || die
make so || die
@@ -21,9 +23,9 @@ src_compile() {
src_install () {
make \
- INSTALL_BIN=${D}/usr/bin \
- INSTALL_MAN=${D}/usr/share/man/man1 \
- INSTALL_INC=${D}/usr/include \
- INSTALL_LIB=${D}/usr/lib \
- install || die
+ INSTALL_BIN=${D}/usr/bin \
+ INSTALL_MAN=${D}/usr/share/man/man1 \
+ INSTALL_INC=${D}/usr/include \
+ INSTALL_LIB=${D}/usr/lib \
+ install || die
}