summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql-super-smack')
-rw-r--r--dev-db/mysql-super-smack/ChangeLog6
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild30
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild30
3 files changed, 41 insertions, 25 deletions
diff --git a/dev-db/mysql-super-smack/ChangeLog b/dev-db/mysql-super-smack/ChangeLog
index 480553f9d436..9620e37ffe16 100644
--- a/dev-db/mysql-super-smack/ChangeLog
+++ b/dev-db/mysql-super-smack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/mysql-super-smack
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/ChangeLog,v 1.8 2006/11/23 20:02:01 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/ChangeLog,v 1.9 2006/12/02 21:03:12 chtekk Exp $
+
+ 02 Dec 2006; Luca Longinotti <chtekk@gentoo.org>
+ mysql-super-smack-1.2.ebuild, mysql-super-smack-1.3.ebuild:
+ Fix bug #155905, cleanup ebuilds.
23 Nov 2006; Francesco Riosa <vivo@gentoo.org>
mysql-super-smack-1.2.ebuild, mysql-super-smack-1.3.ebuild:
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild
index c5fd2c61e53f..30a89a4ab95d 100644
--- a/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild,v 1.6 2006/11/23 20:02:01 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild,v 1.7 2006/12/02 21:03:12 chtekk Exp $
-inherit eutils
+WANT_AUTOMAKE="1.4"
+
+inherit eutils autotools
MY_PN="super-smack"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="MySQL Super Smack is a benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL"
+DESCRIPTION="MySQL Super Smack is a benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL."
HOMEPAGE="http://jeremy.zawodny.com/mysql/${MY_PN}/"
SRC_URI="http://jeremy.zawodny.com/mysql/${MY_PN}/${MY_P}.tar.gz"
@@ -16,9 +18,10 @@ KEYWORDS="x86"
IUSE="mysql postgres"
DEPEND="mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )"
+ postgres? ( dev-db/postgresql )"
+RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
pkg_setup() {
use !mysql && use !postgres && die "You need to use at least one of USE=mysql or USE=postgres for benchmarking!"
@@ -26,22 +29,25 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}.destdir.patch
- cd ${S}
- automake
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}.destdir.patch"
+
+ autotools_set_versions
+ automake || die "automake failed"
}
src_compile() {
- local myconf
+ local myconf=""
use mysql && myconf="${myconf} --with-mysql"
use postgres && myconf="${myconf} --with-pgsql"
myconf="${myconf} --with-datadir=/var/tmp/${MY_PN}"
myconf="${myconf} --with-smacks-dir=/usr/share/${MY_PN}"
- econf ${myconf} || die
- emake || die
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc CHANGES INSTALL MANUAL README TUTORIAL
}
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild
index 2dd8d2b3a45e..2b0cbe82d0bf 100644
--- a/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild,v 1.4 2006/11/23 20:02:01 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild,v 1.5 2006/12/02 21:03:12 chtekk Exp $
-inherit eutils
+WANT_AUTOMAKE="1.4"
+
+inherit eutils autotools
MY_PN="super-smack"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="MySQL Super Smack is a benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL"
+DESCRIPTION="MySQL Super Smack is a benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL."
HOMEPAGE="http://vegan.net/tony/supersmack/"
SRC_URI="http://vegan.net/tony/supersmack/${MY_P}.tar.gz"
@@ -16,7 +18,8 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="mysql postgres"
DEPEND="mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )"
+ postgres? ( dev-db/postgresql )"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -26,23 +29,26 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.2.destdir.patch
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.3.amd64.patch
- automake
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.2.destdir.patch"
+ epatch "${FILESDIR}/${PN}-1.3.amd64.patch"
+
+ autotools_set_versions
+ automake || die "automake failed"
}
src_compile() {
- local myconf
+ local myconf=""
use mysql && myconf="${myconf} --with-mysql"
use postgres && myconf="${myconf} --with-pgsql"
myconf="${myconf} --with-datadir=/var/tmp/${MY_PN}"
myconf="${myconf} --with-smacks-dir=/usr/share/${MY_PN}"
- econf ${myconf} || die
- emake || die
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc CHANGES INSTALL MANUAL README TUTORIAL
}