summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/enhancedcommentify/ChangeLog11
-rw-r--r--app-vim/enhancedcommentify/enhancedcommentify-2.1-r4.ebuild10
-rw-r--r--app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild10
-rw-r--r--app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild26
4 files changed, 45 insertions, 12 deletions
diff --git a/app-vim/enhancedcommentify/ChangeLog b/app-vim/enhancedcommentify/ChangeLog
index f411574a8cbb..04dfc0ee8b45 100644
--- a/app-vim/enhancedcommentify/ChangeLog
+++ b/app-vim/enhancedcommentify/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/enhancedcommentify
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/enhancedcommentify/ChangeLog,v 1.30 2007/03/19 01:11:15 kloeri Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/enhancedcommentify/ChangeLog,v 1.31 2008/04/16 09:03:46 hawking Exp $
+
+*enhancedcommentify-2.3 (16 Apr 2008)
+
+ 16 Apr 2008; Ali Polatel <hawking@gentoo.org>
+ enhancedcommentify-2.1-r4.ebuild, enhancedcommentify-2.2.ebuild,
+ +enhancedcommentify-2.3.ebuild:
+ Version bump. Quoting.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/app-vim/enhancedcommentify/enhancedcommentify-2.1-r4.ebuild b/app-vim/enhancedcommentify/enhancedcommentify-2.1-r4.ebuild
index 7f2765ef821f..ce34dcdaf7ba 100644
--- a/app-vim/enhancedcommentify/enhancedcommentify-2.1-r4.ebuild
+++ b/app-vim/enhancedcommentify/enhancedcommentify-2.1-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/enhancedcommentify/enhancedcommentify-2.1-r4.ebuild,v 1.6 2005/04/24 12:02:58 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/enhancedcommentify/enhancedcommentify-2.1-r4.ebuild,v 1.7 2008/04/16 09:03:46 hawking Exp $
inherit vim-plugin eutils
@@ -20,8 +20,8 @@ RDEPEND="!app-vim/ctx"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# gentooy things, bug #79185
- epatch ${FILESDIR}/${P}-gentooisms.patch
- epatch ${FILESDIR}/${P}-extra-ft-support.patch
+ epatch "${FILESDIR}"/${P}-gentooisms.patch
+ epatch "${FILESDIR}"/${P}-extra-ft-support.patch
}
diff --git a/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild b/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild
index defaad2eb019..4ad43fdbda27 100644
--- a/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild
+++ b/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild,v 1.1 2006/03/04 00:00:36 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/enhancedcommentify/enhancedcommentify-2.2.ebuild,v 1.2 2008/04/16 09:03:46 hawking Exp $
inherit vim-plugin eutils
@@ -19,8 +19,8 @@ RDEPEND="!app-vim/ctx"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# gentooy things, bug #79185
- epatch ${FILESDIR}/${PN}-2.1-gentooisms.patch
- epatch ${FILESDIR}/${PN}-2.1-extra-ft-support.patch
+ epatch "${FILESDIR}"/${PN}-2.1-gentooisms.patch
+ epatch "${FILESDIR}"/${PN}-2.1-extra-ft-support.patch
}
diff --git a/app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild b/app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild
new file mode 100644
index 000000000000..dc2ee85b2f45
--- /dev/null
+++ b/app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild,v 1.1 2008/04/16 09:03:46 hawking Exp $
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: enhanced comment creation"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=23"
+
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="EnhancedCommentify"
+
+DEPEND="${DEPEND} >=sys-apps/sed-4"
+# bug #74897
+RDEPEND="!app-vim/ctx"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # gentooy things, bug #79185
+ epatch "${FILESDIR}"/${PN}-2.1-gentooisms.patch
+ epatch "${FILESDIR}"/${PN}-2.1-extra-ft-support.patch
+}