summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/glastree/files/glastree-posix-make.patch')
-rw-r--r--app-misc/glastree/files/glastree-posix-make.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/app-misc/glastree/files/glastree-posix-make.patch b/app-misc/glastree/files/glastree-posix-make.patch
new file mode 100644
index 000000000000..07e4bf6ec91a
--- /dev/null
+++ b/app-misc/glastree/files/glastree-posix-make.patch
@@ -0,0 +1,16 @@
+Make sure the perl code is valid both with and without the backslashes.
+Some make versions strip them, others don't.
+
+--- glastree-1.04/Makefile
++++ glastree-1.04/Makefile
+@@ -24,8 +24,8 @@
+
+ install:
+ @perl -e 'eval "use Date::Calc"; \
+- print "Checking for prereq Date::Calc..."; \
+- if ($$@) { print "\nThis program requires the Date::Calc module.\n"; exit 1; } \
++ print "Checking for prereq Date::Calc..."; if ($$@) { \
++ print "\nThis program requires the Date::Calc module.\n"; exit 1; } \
+ print " OK\n"; '
+
+ $(INSTALL) -d $(INSTROOT)/$(INSTBIN)