summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/ChangeLog7
-rw-r--r--app-laptop/thinkfan/thinkfan-0.8.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-laptop/thinkfan/ChangeLog b/app-laptop/thinkfan/ChangeLog
index 5a6dc0db93ee..2e929c2e9ace 100644
--- a/app-laptop/thinkfan/ChangeLog
+++ b/app-laptop/thinkfan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/thinkfan
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.4 2012/04/19 22:30:17 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.5 2012/05/12 10:38:07 xmw Exp $
+
+*thinkfan-0.8.0 (12 May 2012)
+
+ 12 May 2012; Michael Weber <xmw@gentoo.org> +thinkfan-0.8.0.ebuild:
+ Version bump
19 Apr 2012; Michael Weber <xmw@gentoo.org> -thinkfan-0.7.3.ebuild:
Remove old version.
diff --git a/app-laptop/thinkfan/thinkfan-0.8.0.ebuild b/app-laptop/thinkfan/thinkfan-0.8.0.ebuild
new file mode 100644
index 000000000000..dce6668b03fb
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/thinkfan-0.8.0.ebuild,v 1.1 2012/05/12 10:38:07 xmw Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd rcscripts/thinkfan.gentoo ${PN}
+
+ doman ${PN}.1
+ dodoc ChangeLog NEWS README \
+ examples/${PN}.conf.{complex,sysfs,thinkpad}
+}
+
+pkg_postinst() {
+ elog "Please read the documentation and copy an"
+ elog "appropriate file to /etc/thinkfan.conf."
+}