summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/playonlinux')
-rw-r--r--app-emulation/playonlinux/ChangeLog8
-rw-r--r--app-emulation/playonlinux/playonlinux-3.8.8.ebuild14
2 files changed, 17 insertions, 5 deletions
diff --git a/app-emulation/playonlinux/ChangeLog b/app-emulation/playonlinux/ChangeLog
index b2bbc81b5451..56f10fe00090 100644
--- a/app-emulation/playonlinux/ChangeLog
+++ b/app-emulation/playonlinux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/playonlinux
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.11 2010/12/26 16:00:04 volkmar Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.12 2011/04/16 20:28:27 arfrever Exp $
+
+ 16 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ playonlinux-3.8.8.ebuild:
+ Use Python 2 (bug #363879).
*playonlinux-3.8.8 (26 Dec 2010)
diff --git a/app-emulation/playonlinux/playonlinux-3.8.8.ebuild b/app-emulation/playonlinux/playonlinux-3.8.8.ebuild
index ce82d86a8c1a..ed0052c43abc 100644
--- a/app-emulation/playonlinux/playonlinux-3.8.8.ebuild
+++ b/app-emulation/playonlinux/playonlinux-3.8.8.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-3.8.8.ebuild,v 1.2 2011/03/01 03:22:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-3.8.8.ebuild,v 1.3 2011/04/16 20:28:27 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
inherit eutils python games
@@ -37,9 +38,16 @@ S=${WORKDIR}/${PN}
# How to deal with wine version installed ? (have a better mgmt of system one)
# Look at debian pkg: http://packages.debian.org/sid/playonlinux
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
sed -i -e "s/\(Categories=\).*/\1Game;Emulator;/" etc/PlayOnLinux.desktop \
|| die "sed failed"
+ sed -e 's/PYTHON="python"/PYTHON="python2"/' -i lib/variables || die "sed failed"
+ python_convert_shebangs -r 2 .
}
src_install() {