summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/keynote')
-rw-r--r--app-crypt/keynote/ChangeLog10
-rw-r--r--app-crypt/keynote/Manifest2
-rw-r--r--app-crypt/keynote/files/digest-keynote-2.31
-rw-r--r--app-crypt/keynote/keynote-2.3.ebuild44
4 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/keynote/ChangeLog b/app-crypt/keynote/ChangeLog
new file mode 100644
index 000000000000..6238afa481b3
--- /dev/null
+++ b/app-crypt/keynote/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/keynote
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.1 2003/12/23 15:29:33 plasmaroo Exp $
+
+*keynote-2.3 (23 Dec 2003)
+
+ 23 Dec 2003; <plasmaroo@gentoo.org> keynote-2.3.ebuild:
+ Initial commit. This ebuild was kindly contributed by Sebastien
+ Estienne, bug #27279.
+
diff --git a/app-crypt/keynote/Manifest b/app-crypt/keynote/Manifest
new file mode 100644
index 000000000000..5ff21e10aecf
--- /dev/null
+++ b/app-crypt/keynote/Manifest
@@ -0,0 +1,2 @@
+MD5 fcaff227c43da94d15436f2a45227b51 ChangeLog 397
+MD5 96f15a251afacd6c0fd388131f1a55d4 keynote-2.3.ebuild 850
diff --git a/app-crypt/keynote/files/digest-keynote-2.3 b/app-crypt/keynote/files/digest-keynote-2.3
new file mode 100644
index 000000000000..f0cb7698c9ec
--- /dev/null
+++ b/app-crypt/keynote/files/digest-keynote-2.3
@@ -0,0 +1 @@
+MD5 ba58a0297c421dc6aa671e6b753ef695 keynote-2.3.tar.gz 141930
diff --git a/app-crypt/keynote/keynote-2.3.ebuild b/app-crypt/keynote/keynote-2.3.ebuild
new file mode 100644
index 000000000000..8a7621386fc0
--- /dev/null
+++ b/app-crypt/keynote/keynote-2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/keynote-2.3.ebuild,v 1.1 2003/12/23 15:29:33 plasmaroo Exp $
+
+DESCRIPTION="The KeyNote Trust-Management System"
+HOMEPAGE="http://www1.cs.columbia.edu/~angelos/keynote.html"
+SRC_URI="http://www1.cs.columbia.edu/~angelos/Code/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl"
+
+DEPEND="virtual/glibc
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+
+ econf || die
+ if [ -n "`use ssl`" ]; then
+ make || die
+ else
+ make nocrypto || die
+ fi
+
+}
+
+src_install() {
+
+ dobin keynote
+
+ doman man/keynote.1
+ doman man/keynote.3
+ doman man/keynote.4
+ doman man/keynote.5
+
+ dolib.a libkeynote.a
+
+ insinto /usr/include
+ doins keynote.h
+
+ dodoc README HOWTO.add.crypto TODO LICENSE
+
+}