summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/supervisor/supervisor-3.0_alpha8.ebuild')
-rw-r--r--app-admin/supervisor/supervisor-3.0_alpha8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/supervisor/supervisor-3.0_alpha8.ebuild b/app-admin/supervisor/supervisor-3.0_alpha8.ebuild
new file mode 100644
index 000000000000..67fdfd358660
--- /dev/null
+++ b/app-admin/supervisor/supervisor-3.0_alpha8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/supervisor-3.0_alpha8.ebuild,v 1.1 2010/03/09 13:45:31 djc Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils versionator eutils
+
+MY_PV="${PV/_alpha/a}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ http://pypi.python.org/pypi/supervisor"
+SRC_URI="http://dist.supervisord.org/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="repoze ZPL BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools
+ test? ( dev-python/mock )"
+RDEPEND="dev-python/meld3"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}"/init.d supervisord
+ newconfd "${FILESDIR}"/conf.d supervisord
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py test
+ }
+ python_execute_function testing
+}