summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-02-06 15:19:31 +0000
committerJeroen Roovers <jer@gentoo.org>2013-02-06 15:19:31 +0000
commita917bc38665daa047a3b05249a76891a6515986e (patch)
tree2b07f14e17dab7aea95bd1a2f56dcb512d40b3d6 /x11-wm
parentAdd missing virtualx inherit wrt bug #452810. (diff)
downloadgentoo-2-a917bc38665daa047a3b05249a76891a6515986e.tar.gz
gentoo-2-a917bc38665daa047a3b05249a76891a6515986e.tar.bz2
gentoo-2-a917bc38665daa047a3b05249a76891a6515986e.zip
Verbose build.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-6.0.ebuild14
2 files changed, 14 insertions, 7 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index 428cd3f0f909..739a600f43ed 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/dwm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.87 2012/05/03 14:40:04 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.88 2013/02/06 15:19:31 jer Exp $
+
+ 06 Feb 2013; Jeroen Roovers <jer@gentoo.org> dwm-6.0.ebuild:
+ Verbose build.
03 May 2012; Jeroen Roovers <jer@gentoo.org> dwm-6.0.ebuild:
Add support for epatch_user by Marvin Vek (bug #414481).
diff --git a/x11-wm/dwm/dwm-6.0.ebuild b/x11-wm/dwm/dwm-6.0.ebuild
index ad2bbea935b1..33c4f6b2ba89 100644
--- a/x11-wm/dwm/dwm-6.0.ebuild
+++ b/x11-wm/dwm/dwm-6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-6.0.ebuild,v 1.11 2012/05/03 14:40:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-6.0.ebuild,v 1.12 2013/02/06 15:19:31 jer Exp $
EAPI="4"
@@ -31,7 +31,11 @@ src_prepare() {
-e "s@/usr/X11R6/include@${EPREFIX}/usr/include/X11@" \
-e "s@/usr/X11R6/lib@${EPREFIX}/usr/lib@" \
-e "s@-I/usr/include@@" -e "s@-L/usr/lib@@" \
- config.mk || die "sed failed"
+ config.mk || die
+ sed -i \
+ -e '/@echo CC/d' \
+ -e 's|@${CC}|$(CC)|g' \
+ Makefile || die
restore_config config.h
epatch_user
@@ -39,9 +43,9 @@ src_prepare() {
src_compile() {
if use xinerama; then
- emake CC=$(tc-getCC)
+ emake CC=$(tc-getCC) dwm
else
- emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS=""
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" dwm
fi
}