summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-07-19 20:21:41 +0000
committerAlex Alexander <wired@gentoo.org>2010-07-19 20:21:41 +0000
commita4dae9a6cb743a5a612a786e004b4f76031c9128 (patch)
tree24a8bc4ae29f2dd9cfdb62dda353018b4ff60540 /x11-themes/qtcurve-qt4
parentdrop system libc re-emerge message for linux-headers #328317 (diff)
downloadgentoo-2-a4dae9a6cb743a5a612a786e004b4f76031c9128.tar.gz
gentoo-2-a4dae9a6cb743a5a612a786e004b4f76031c9128.tar.bz2
gentoo-2-a4dae9a6cb743a5a612a786e004b4f76031c9128.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/qtcurve-qt4')
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog7
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-1.5.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index ca83e782099a..41407552afee 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve-qt4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.107 2010/07/09 13:19:19 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.108 2010/07/19 20:21:41 wired Exp $
+
+*qtcurve-qt4-1.5.2 (19 Jul 2010)
+
+ 19 Jul 2010; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-1.5.2.ebuild:
+ version bump
*qtcurve-qt4-1.5.1 (09 Jul 2010)
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-1.5.2.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.5.2.ebuild
new file mode 100644
index 000000000000..bbf3af0d1bc0
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-1.5.2.ebuild,v 1.1 2010/07/19 20:21:41 wired Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+KDE_MINIMAL="4.2"
+inherit confutils cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde windeco"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-svg:4
+ kde? ( >=kde-base/systemsettings-${KDE_MINIMAL}
+ windeco? ( >=kde-base/kwin-${KDE_MINIMAL} ) )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+ confutils_use_depend_all windeco kde
+ use kde && kde4-base_pkg_setup
+}
+
+src_configure() {
+ if use kde; then
+ kde4-base_src_configure
+ else
+ mycmakeargs="-DQTC_QT_ONLY=true"
+ cmake-utils_src_configure
+ fi
+}