summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-04-16 21:17:31 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-04-16 21:17:31 +0000
commit408273f2b0d2f70ca39bec1a9b35ae9592d7126a (patch)
treeac5557b4521bcb71686f5615d0a11f70c7115f18 /x11-terms
parentDrop KDE 4.2.1 (diff)
downloadgentoo-2-408273f2b0d2f70ca39bec1a9b35ae9592d7126a.tar.gz
gentoo-2-408273f2b0d2f70ca39bec1a9b35ae9592d7126a.tar.bz2
gentoo-2-408273f2b0d2f70ca39bec1a9b35ae9592d7126a.zip
Bump pssh-1.4.3 (#265810), fixes deprecation warnings with python-2.6
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/pssh/ChangeLog9
-rw-r--r--x11-terms/pssh/pssh-1.4.3.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/x11-terms/pssh/ChangeLog b/x11-terms/pssh/ChangeLog
index cc403a432dbf..66f28e8720ec 100644
--- a/x11-terms/pssh/ChangeLog
+++ b/x11-terms/pssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/pssh
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/ChangeLog,v 1.9 2008/05/29 18:21:20 hawking Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/ChangeLog,v 1.10 2009/04/16 21:17:31 jsbronder Exp $
+
+*pssh-1.4.3 (16 Apr 2009)
+
+ 16 Apr 2009; Justin Bronder <jsbronder@gentoo.org> +pssh-1.4.3.ebuild:
+ Bump pssh-1.4.3 (#265810), fixes deprecation warnings with python-2.6
29 May 2008; Ali Polatel <hawking@gentoo.org> pssh-1.3.1.ebuild:
python_mod_optimize is ROOT aware.
diff --git a/x11-terms/pssh/pssh-1.4.3.ebuild b/x11-terms/pssh/pssh-1.4.3.ebuild
new file mode 100644
index 000000000000..65e22ab161b9
--- /dev/null
+++ b/x11-terms/pssh/pssh-1.4.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/pssh-1.4.3.ebuild,v 1.1 2009/04/16 21:17:31 jsbronder Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils multilib python
+
+DESCRIPTION="This package provides parallel versions of the openssh tools."
+HOMEPAGE="http://www.theether.org/pssh"
+SRC_URI="http://www.theether.org/pssh/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="net-misc/openssh"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+# Requires ssh access to run.
+RESTRICT="test"
+DOCS="BUGS"
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/psshlib
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}