summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-11-12 15:45:17 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-11-12 15:45:17 +0000
commit7c3e24ab40ec4fb0ef2501495782f740a9bacda2 (patch)
tree6af7bdf0b115988f6f7f95cee1f2964909a94dbd /x11-plugins
parentAutomated update. (diff)
downloadgentoo-2-7c3e24ab40ec4fb0ef2501495782f740a9bacda2.tar.gz
gentoo-2-7c3e24ab40ec4fb0ef2501495782f740a9bacda2.tar.bz2
gentoo-2-7c3e24ab40ec4fb0ef2501495782f740a9bacda2.zip
Version bump with new homepage, also fixes bug #514220
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmbiff/ChangeLog7
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.28.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-plugins/wmbiff/ChangeLog b/x11-plugins/wmbiff/ChangeLog
index 1cc9f03b5a84..a7079d43be37 100644
--- a/x11-plugins/wmbiff/ChangeLog
+++ b/x11-plugins/wmbiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmbiff
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/ChangeLog,v 1.38 2014/08/12 00:08:20 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/ChangeLog,v 1.39 2014/11/12 15:45:17 voyageur Exp $
+
+*wmbiff-0.4.28 (12 Nov 2014)
+
+ 12 Nov 2014; Bernard Cafarelli <voyageur@gentoo.org> +wmbiff-0.4.28.ebuild:
+ Version bump with new homepage, also fixes bug #514220
12 Aug 2014; Anthony G. Basile <blueness@gentoo.org> wmbiff-0.4.27-r1.ebuild:
Stable on ppc, bug #506914
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.28.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.28.ebuild
new file mode 100644
index 000000000000..cf87e5dbaa17
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.28.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.28.ebuild,v 1.1 2014/11/12 15:45:17 voyageur Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmbiff"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1:0
+ >=net-libs/gnutls-2.2.0
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/dockapps
+
+DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable crypt crypto)
+}