summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:37:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:37:15 +0000
commit45599c6599072d2b608465d22803df6b20668d59 (patch)
tree483479388afb046b885c0be4ede48d48fc6bac30 /x11-plugins
parentarm stable, bug #497760 (diff)
downloadgentoo-2-45599c6599072d2b608465d22803df6b20668d59.tar.gz
gentoo-2-45599c6599072d2b608465d22803df6b20668d59.tar.bz2
gentoo-2-45599c6599072d2b608465d22803df6b20668d59.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmcliphist/ChangeLog8
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild18
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-1.0.ebuild7
3 files changed, 17 insertions, 16 deletions
diff --git a/x11-plugins/wmcliphist/ChangeLog b/x11-plugins/wmcliphist/ChangeLog
index 961f8f2a684a..8ac48107dad5 100644
--- a/x11-plugins/wmcliphist/ChangeLog
+++ b/x11-plugins/wmcliphist/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmcliphist
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/ChangeLog,v 1.18 2012/08/27 09:26:54 voyageur Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/ChangeLog,v 1.19 2014/04/07 19:37:15 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> wmcliphist-0.6-r1.ebuild,
+ wmcliphist-1.0.ebuild:
+ Use EAPI5 instead of EAPI1.
*wmcliphist-1.0 (27 Aug 2012)
diff --git a/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild b/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild
index 36ff785a2b2b..a6fe3ceb684f 100644
--- a/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild
+++ b/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild,v 1.7 2012/05/05 05:12:01 jdhore Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild,v 1.8 2014/04/07 19:37:15 ssuominen Exp $
+EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="Dockable clipboard history application for Window Maker"
@@ -19,16 +18,15 @@ RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-Makefile.patch
- epatch "${FILESDIR}"/${P}-fix-docking.patch
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-fix-docking.patch
}
src_compile() {
tc-export CC
- emake || die "emake failed."
+ emake
}
src_install() {
diff --git a/x11-plugins/wmcliphist/wmcliphist-1.0.ebuild b/x11-plugins/wmcliphist/wmcliphist-1.0.ebuild
index 7475017ba399..eb1c4c0af4d6 100644
--- a/x11-plugins/wmcliphist/wmcliphist-1.0.ebuild
+++ b/x11-plugins/wmcliphist/wmcliphist-1.0.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-1.0.ebuild,v 1.1 2012/08/27 09:26:54 voyageur Exp $
-
-EAPI=4
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-1.0.ebuild,v 1.2 2014/04/07 19:37:15 ssuominen Exp $
+EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="Dockable clipboard history application for Window Maker"