summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-04 14:49:33 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-04 14:49:33 +0000
commitb72585ae0af8b889023fc6f7ad146f3707d8fc38 (patch)
tree022b9dbe4a7b763bb3a806a1083c7ebb4f8f99a7 /x11-plugins/wmcp
parentUpped dependancy to >=fltk-1.1.0_rc7 and included virtual/x11. Added (diff)
downloadgentoo-2-b72585ae0af8b889023fc6f7ad146f3707d8fc38.tar.gz
gentoo-2-b72585ae0af8b889023fc6f7ad146f3707d8fc38.tar.bz2
gentoo-2-b72585ae0af8b889023fc6f7ad146f3707d8fc38.zip
Initial add of ebuild to portage. A pager dockapp.
Diffstat (limited to 'x11-plugins/wmcp')
-rw-r--r--x11-plugins/wmcp/ChangeLog10
-rw-r--r--x11-plugins/wmcp/files/digest-wmcp-1.2.81
-rw-r--r--x11-plugins/wmcp/files/makefile.diff13
-rw-r--r--x11-plugins/wmcp/wmcp-1.2.8.ebuild38
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-plugins/wmcp/ChangeLog b/x11-plugins/wmcp/ChangeLog
new file mode 100644
index 000000000000..f33323d44aaa
--- /dev/null
+++ b/x11-plugins/wmcp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-plugins/wmcp
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcp/ChangeLog,v 1.1 2002/10/04 14:49:33 raker Exp $
+
+*wmcp-1.2.8 (04 Oct 2002)
+
+ 04 Oct 2002; Nick Hadaway <raker@gentoo.org> wmcp-1.2.8.ebuild,
+ files/digest-wmcp-1.2.8, files/makefile.diff :
+ Initial add of ebuild to portage. NOTE: This package doesn't appear
+ to have a homepage anymore but it is still on the tucows mirrors.
diff --git a/x11-plugins/wmcp/files/digest-wmcp-1.2.8 b/x11-plugins/wmcp/files/digest-wmcp-1.2.8
new file mode 100644
index 000000000000..9e78436d8752
--- /dev/null
+++ b/x11-plugins/wmcp/files/digest-wmcp-1.2.8
@@ -0,0 +1 @@
+MD5 6f347dd6fb0b017de868081088cdcf13 wmcp-1.2.8.tar.gz 8673
diff --git a/x11-plugins/wmcp/files/makefile.diff b/x11-plugins/wmcp/files/makefile.diff
new file mode 100644
index 000000000000..273dd23877ba
--- /dev/null
+++ b/x11-plugins/wmcp/files/makefile.diff
@@ -0,0 +1,13 @@
+diff -urN wmcp-1.2.8/Makefile wmcp-1.2.8-modified/Makefile
+--- wmcp-1.2.8/Makefile 2002-10-04 09:40:22.000000000 -0500
++++ wmcp-1.2.8-modified/Makefile 2002-10-04 09:46:45.000000000 -0500
+@@ -1,7 +1,7 @@
+
+
+-INCLUDES =-I/usr/X11R6/include/X11 -I/usr/local/include -I/usr/include/X11R6/X11
+-LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
++INCLUDES =-I/usr/X11R6/include/X11
++LIBINC =-L/usr/X11R6/lib
+ LIBS = -lm -lX11 -lXpm -lXext
+
+ TARGET = wmcp
diff --git a/x11-plugins/wmcp/wmcp-1.2.8.ebuild b/x11-plugins/wmcp/wmcp-1.2.8.ebuild
new file mode 100644
index 000000000000..58fb14b61716
--- /dev/null
+++ b/x11-plugins/wmcp/wmcp-1.2.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcp/wmcp-1.2.8.ebuild,v 1.1 2002/10/04 14:49:33 raker Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="A pager dockapp"
+HOMEPAGE="http://www.the.page.doesnt.seem.to.exist.anymore.com"
+SRC_URI="http://linux-sea.tucows.webusenet.com/files/x11/dock/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/makefile.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ make || die "make failed"
+
+}
+
+src_install() {
+
+ cd ${S}
+ dobin wmcp
+
+}