summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-07 01:00:14 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-07 01:00:14 +0000
commitd83da0ee3703f2f2ab506b025d67db312707f956 (patch)
treea0d7a0ba0caeca19d758d3c4451565e0e3ab5e91 /x11-misc
parentRemove old version (diff)
downloadgentoo-2-d83da0ee3703f2f2ab506b025d67db312707f956.tar.gz
gentoo-2-d83da0ee3703f2f2ab506b025d67db312707f956.tar.bz2
gentoo-2-d83da0ee3703f2f2ab506b025d67db312707f956.zip
Fix GCC 4 compile error (bug #150823), wxGTK usage, and general Makefile
cruddiness. (Portage version: 2.1.2.6)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/jaffm/ChangeLog7
-rw-r--r--x11-misc/jaffm/files/jaffm-1.2.1-gcc41.patch12
-rw-r--r--x11-misc/jaffm/jaffm-1.2.1.ebuild27
-rw-r--r--x11-misc/jaffm/jaffm-1.3.ebuild22
4 files changed, 54 insertions, 14 deletions
diff --git a/x11-misc/jaffm/ChangeLog b/x11-misc/jaffm/ChangeLog
index 34e7fb2cab69..ed72fc9ed6da 100644
--- a/x11-misc/jaffm/ChangeLog
+++ b/x11-misc/jaffm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/jaffm
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/jaffm/ChangeLog,v 1.15 2007/02/21 23:46:44 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/jaffm/ChangeLog,v 1.16 2007/05/07 01:00:14 dirtyepic Exp $
+
+ 07 May 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/jaffm-1.2.1-gcc41.patch, jaffm-1.2.1.ebuild, jaffm-1.3.ebuild:
+ Fix GCC 4 compile error (bug #150823), wxGTK usage, and general Makefile
+ cruddiness.
21 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-misc/jaffm/files/jaffm-1.2.1-gcc41.patch b/x11-misc/jaffm/files/jaffm-1.2.1-gcc41.patch
new file mode 100644
index 000000000000..818e1bb2ccb0
--- /dev/null
+++ b/x11-misc/jaffm/files/jaffm-1.2.1-gcc41.patch
@@ -0,0 +1,12 @@
+diff -Naur jaffm-1.2.1-orig/filetree.h jaffm-1.2.1/filetree.h
+--- jaffm-1.2.1-orig/filetree.h 2007-04-30 21:53:27.000000000 -0600
++++ jaffm-1.2.1/filetree.h 2007-04-30 21:57:44.000000000 -0600
+@@ -20,7 +20,7 @@
+ public:
+ UFiletree(wxWindow *oParent, wxWindowID iID, wxTextCtrl *oLocation, MainWindow *oParentWindow, Settings *oNewSettings);
+
+- wxTreeItemId UFiletree::GetParent(wxTreeItemId item) const { return GetItemParent(item); }
++ wxTreeItemId GetParent(wxTreeItemId item) const { return GetItemParent(item); }
+ wxString getFullpath(wxTreeItemId iItem);
+ void selectPrevItem();
+ void selectNextItem();
diff --git a/x11-misc/jaffm/jaffm-1.2.1.ebuild b/x11-misc/jaffm/jaffm-1.2.1.ebuild
index d5b33a59c359..b045b546c4d9 100644
--- a/x11-misc/jaffm/jaffm-1.2.1.ebuild
+++ b/x11-misc/jaffm/jaffm-1.2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/jaffm/jaffm-1.2.1.ebuild,v 1.6 2006/04/10 19:52:01 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/jaffm/jaffm-1.2.1.ebuild,v 1.7 2007/05/07 01:00:14 dirtyepic Exp $
-inherit eutils
+inherit eutils toolchain-funcs wxwidgets
DESCRIPTION="Very lightweight file manager"
HOMEPAGE="http://jaffm.binary.is/"
@@ -15,15 +15,22 @@ SLOT="0"
KEYWORDS="~ppc x86"
IUSE=""
-DEPEND=">=x11-libs/wxGTK-2.6"
+DEPEND="=x11-libs/wxGTK-2.6*"
src_unpack() {
- unpack "${A}"
- epatch "${FILESDIR}/${P}-wx24.patch"
-}
-
-src_compile() {
- emake || die
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-wx24.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+
+ WX_GTK_VER="2.6"
+ need-wxwidgets gtk2
+ sed -i \
+ -e "/^CPP=/ s:g++:$(tc-getCXX):" \
+ -e "/^PREFIX=/ s:/local::" \
+ -e "s:wx-config:${WX_CONFIG}:g" \
+ -e "/^FLAGS=/ s:^.*$:FLAGS=${CXXFLAGS}:" \
+ Makefile
}
src_install() {
diff --git a/x11-misc/jaffm/jaffm-1.3.ebuild b/x11-misc/jaffm/jaffm-1.3.ebuild
index 2eb4e9ef32c2..d02bf0785655 100644
--- a/x11-misc/jaffm/jaffm-1.3.ebuild
+++ b/x11-misc/jaffm/jaffm-1.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/jaffm/jaffm-1.3.ebuild,v 1.1 2006/05/21 10:12:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/jaffm/jaffm-1.3.ebuild,v 1.2 2007/05/07 01:00:14 dirtyepic Exp $
+
+inherit toolchain-funcs wxwidgets
DESCRIPTION="Very lightweight file manager"
HOMEPAGE="http://jaffm.binary.is/"
@@ -13,7 +15,21 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
-DEPEND=">=x11-libs/wxGTK-2.6"
+DEPEND="=x11-libs/wxGTK-2.6*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ WX_GTK_VER="2.6"
+ need-wxwidgets gtk2
+ sed -i \
+ -e "/^CPP=/ s:g++:$(tc-getCXX):" \
+ -e "/^PREFIX=/ s:/local::" \
+ -e "s:wx-config:${WX_CONFIG}:g" \
+ -e "/^FLAGS=/ s:^.*$:FLAGS=${CXXFLAGS}:" \
+ Makefile
+}
src_install() {
dobin jaffm